The default bug view has changed. See this FAQ.

fennec build configs should define MOZ_TELEMETRY_REPORTING

RESOLVED FIXED in Firefox 15

Status

()

Firefox for Android
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: froydnj, Assigned: mbrubeck)

Tracking

unspecified
Firefox 16
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 wontfix, firefox15+ fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
bug 722240 disabled telemetry for non-official builds based on the presence of MOZ_TELEMETRY_REPORTING.  Unfortunately, the Android builds don't define MOZ_TELEMETRY_REPORTING, so bug 722240 completely disabled telemetry for them.

We should add the necessary logic in the mozconfigs.  Probably shouldn't uplift this until at least bug 762620 is resolved.
Depends on: 762620
(Reporter)

Comment 1

5 years ago
Created attachment 632299 [details] [diff] [review]
patch to add MOZ_TELEMETRY_REPORTING

Wasn't sure about the android-{armv6,x86} builds, decided to add the necessary stanzas there too.

Wasn't sure about the l10n-* configs, decided to follow existing practice and not add them.
Attachment #632299 - Flags: review?(blassey.bugs)
Attachment #632299 - Flags: review?(blassey.bugs) → review+
(Assignee)

Comment 2

5 years ago
Created attachment 632434 [details] [diff] [review]
Disable telemetry prompt in non-telemetry builds

In addition, we should disable the telemetry UI in builds without telemetry.
Attachment #632434 - Flags: review?(mark.finkle)
Comment on attachment 632434 [details] [diff] [review]
Disable telemetry prompt in non-telemetry builds

>diff --git a/mobile/android/chrome/content/browser.js b/mobile/android/chrome/content/browser.js

>+#ifdef MOZ_TELEMETRY_REPORTING
>     Telemetry.init();
>+#endif

You missed a Telemetry.unint();

r+ with that change
Attachment #632434 - Flags: review?(mark.finkle) → review+
(Reporter)

Comment 4

5 years ago
(In reply to Matt Brubeck (:mbrubeck) from comment #2)
> Disable telemetry prompt in non-telemetry builds

Matt, do you want to land this patch prior to mine, or does it not really matter?
(Assignee)

Comment 5

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #3)
> You missed a Telemetry.unint();

Fixed.

(In reply to Nathan Froyd (:froydnj) from comment #4)
> Matt, do you want to land this patch prior to mine, or does it not really
> matter?

Landed both patches together:
https://hg.mozilla.org/integration/mozilla-inbound/rev/112ab5ba3ac4
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b447b08eb73

Do we also want these on Aurora and Beta, or should we wait until bug 762620 is resolved?
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
status-firefox14: --- → affected
status-firefox15: --- → affected
Target Milestone: --- → Firefox 16
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/112ab5ba3ac4
https://hg.mozilla.org/mozilla-central/rev/7b447b08eb73
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 632299 [details] [diff] [review]
patch to add MOZ_TELEMETRY_REPORTING

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 762590, Bug 764144 and Bug 762620
User impact if declined: No Telemetry on Fennec
Testing completed (on m-c, etc.): Has been in m-c for a while.
Risk to taking this patch (and alternatives if risky): Now that bug 762590 and 762620 are fixed, I'd say very low risk of accidentally using up battery/user data quota.
Attachment #632299 - Flags: approval-mozilla-beta?
Attachment #632299 - Flags: approval-mozilla-aurora?

Updated

5 years ago
status-firefox14: affected → wontfix
tracking-firefox15: --- → +

Comment 8

5 years ago
Comment on attachment 632299 [details] [diff] [review]
patch to add MOZ_TELEMETRY_REPORTING

[Triage Comment]
I wish this had been nominated for uplift sooner - we can't risk any regressions to power consumption in 14.0.1 and I'm not comfortable with going out having only had the device coverage testing we've gotten on Nightlies so far. Let's get this into Aurora 15, however. If anybody disagrees, please email/ping me directly as we're hours away from going to build.
Attachment #632299 - Flags: approval-mozilla-beta?
Attachment #632299 - Flags: approval-mozilla-beta-
Attachment #632299 - Flags: approval-mozilla-aurora?
Attachment #632299 - Flags: approval-mozilla-aurora+
Comment on attachment 632299 [details] [diff] [review]
patch to add MOZ_TELEMETRY_REPORTING

Alex, the reason we scrambled to get idle-daily fixed was to turn on telemetry for 14.01, renominating.
Attachment #632299 - Flags: approval-mozilla-beta- → approval-mozilla-beta?
Comment on attachment 632299 [details] [diff] [review]
patch to add MOZ_TELEMETRY_REPORTING

[Triage comment]
Blassey and I spoke further about this. Based upon the risk in bug 762620, we actually backed that out. Given that, no need to land this on beta.
Attachment #632299 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
(Assignee)

Comment 11

5 years ago
Pushed the patch to enable telemetry at build time:
https://hg.mozilla.org/releases/mozilla-aurora/rev/34379dbcf2cc

Note: I did not uplift the second patch, to disable the Telemetry UI in unofficial builds, because it is not approved and does not apply cleanly to Aurora.  Since that patch only affects unofficial builds, it's not a priority for Aurora uplift.
status-firefox15: affected → fixed
You need to log in before you can comment on or make changes to this bug.