Last Comment Bug 764019 - Remove our prefetch when READOPS=0 on windows
: Remove our prefetch when READOPS=0 on windows
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on: 757215
Blocks: 764905
  Show dependency treegraph
 
Reported: 2012-06-12 10:05 PDT by (dormant account)
Modified: 2012-06-14 23:25 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Only rely on the maintenance service to enable preload on Windows (1.82 KB, patch)
2012-06-13 00:42 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Only rely on the maintenance service to enable preload on Windows (1.82 KB, patch)
2012-06-13 04:33 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Only rely on the maintenance service to enable preload on Windows (1.79 KB, patch)
2012-06-13 06:29 PDT, Mike Hommey [:glandium]
taras.mozilla: review+
Details | Diff | Splinter Review

Description (dormant account) 2012-06-12 10:05:49 PDT
bug 757215 shows that my heuristic a slight loss. We should focus any profiling/optimization on the case where we know prefetch is nuked for us, ie bug 692255.
Comment 1 Mike Hommey [:glandium] 2012-06-13 00:42:14 PDT
Created attachment 632586 [details] [diff] [review]
Only rely on the maintenance service to enable preload on Windows

I think the experiment we were talking about yesterday would be a separate bug.
Comment 2 Mike Hommey [:glandium] 2012-06-13 04:33:02 PDT
Created attachment 632636 [details] [diff] [review]
Only rely on the maintenance service to enable preload on Windows

Need to leave ioCounters there because it's used for *GLUESTARTUP_READ_OPS and *GLUESTARTUP_READ_TRANSFER.
Comment 3 Brian R. Bondy [:bbondy] 2012-06-13 06:10:36 PDT
Comment on attachment 632636 [details] [diff] [review]
Only rely on the maintenance service to enable preload on Windows

Review of attachment 632636 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/app/nsBrowserApp.cpp
@@ -234,5 @@
>    if (IsPrefetchDisabledViaService()) {
>      preloadReason = PRELOAD_SERVICE;
> -  } else if ((gotCounters && !ioCounters.ReadOperationCount)) {
> -    preloadReason = PRELOAD_IOCOUNT;
> -  }

You need to keep this closing brace otherwise it won't compile.
Comment 4 Mike Hommey [:glandium] 2012-06-13 06:29:28 PDT
Created attachment 632667 [details] [diff] [review]
Only rely on the maintenance service to enable preload on Windows

(In reply to Brian R. Bondy [:bbondy] from comment #3)
> @@ -234,5 @@
> >    if (IsPrefetchDisabledViaService()) {
> >      preloadReason = PRELOAD_SERVICE;
> > -  } else if ((gotCounters && !ioCounters.ReadOperationCount)) {
> > -    preloadReason = PRELOAD_IOCOUNT;
> > -  }
> 
> You need to keep this closing brace otherwise it won't compile.

Yeah, try just told me so :)
Comment 5 Mike Hommey [:glandium] 2012-06-14 23:25:55 PDT
https://hg.mozilla.org/mozilla-central/rev/da76a072b2b0

Note You need to log in before you can comment on or make changes to this bug.