Closed Bug 764346 Opened 8 years ago Closed 8 years ago

Error console filter doesn't match address of source

Categories

(Toolkit Graveyard :: Error Console, defect)

defect
Not set

Tracking

(firefox16 disabled, firefox17 disabled)

RESOLVED FIXED
mozilla16
Tracking Status
firefox16 --- disabled
firefox17 --- disabled

People

(Reporter: darktrojan, Assigned: evilpie)

References

Details

Attachments

(2 files)

Filtering for 'bugz' on the error console will show the messages that match, but not the CSS warnings about bugzilla. We should test against the address too.
Sure, I can fix this easily. At the moment, I only matched against the actually message (msg) part. One easy catch all solution would be to match against the stringified entry.
Assignee: nobody → evilpies
I'm not sure, but I don't think we should filter on the line number or timestamp.
Looking at consoleBindings.xml (http://mxr.mozilla.org/mozilla-central/source/toolkit/components/console/content/consoleBindings.xml#196), I think we should filter on the following:

- msg
- href
- code
- line

I took a look at what the Web Console searches on and they include the following in attributes in their search (http://mxr.mozilla.org/mozilla-central/source/browser/devtools/webconsole/HUDService.jsm#3945):

- aBody
- aSourceURL
- aSourceLine

Note that with the way that the Web Console does their searches, you can also include a ':' in your search filter and get back results even though that character is inserted between the URL and line number.
Wow Jared thank you very much for this deep analysis!
Attachment #633791 - Flags: review?(jaws)
Comment on attachment 633791 [details] [diff] [review]
Filter on addional attributes

Review of attachment 633791 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for not getting to this sooner. I will try to review it tomorrow.
Comment on attachment 633791 [details] [diff] [review]
Filter on addional attributes

Review of attachment 633791 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good :)
Attachment #633791 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/16b70566af66
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16
[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 760951, not ready to ship
User impact if declined: error console filters won't work great, need to back this out to back out bug 760951
Testing completed (on m-c, etc.): locally, and backed out on 16-aurora
Risk to taking this patch (and alternatives if risky): none expected
String or UUID changes made by this patch: none
Attachment #669341 - Flags: approval-mozilla-beta?
Attachment #669341 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Backed out of firefox17-beta because bug 763821 didn't get fixed until firefox18:
https://hg.mozilla.org/releases/mozilla-beta/rev/4eaef696723e
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.