Closed Bug 76450 Opened 20 years ago Closed 20 years ago

inital focus on page load has regressed

Categories

(Core :: XUL, defect, P1)

x86
All
defect

Tracking

()

RESOLVED FIXED
mozilla0.9

People

(Reporter: saari, Assigned: saari)

References

Details

(Keywords: access, regression, Whiteboard: need4emb-0.9 - tested have r,sr a=brendan - ready to check in)

Attachments

(4 files)

load google.com, shift-tab twice to get into urlbar, type. 
On mac you don't see a caret until you type, but then it works.
On windows, you don't get a caret or characters *unless* you click in the 
google search field and then do tabbing.
On linux, it just doesn't work at all.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1
On my win2k box I am now seeing that it doesn't work unless you click in the URL
bar first. Clicking in the content's text box doesn't matter. Once you've
clicked in the URL bar it works fine until you try another page. It *will*
continue to work if you just reload the same page. 
Okay when it doesn't work, ESM::GetNextTabbableContent returns null for next
tabbable content. It looks like mCurrentFocus doesn't get nulled out
appropriately when we first set focus to the text field in the content away from
the URL bar, so when we try to set it back, it hits the new focus ==
mCurrentFocus check and bails.

When it does work, that check doesn't get hit and all is well.
*** Bug 76614 has been marked as a duplicate of this bug. ***
Priority: -- → P1
Whiteboard: needed for 0.9
Target Milestone: mozilla0.9.1 → mozilla0.9
Attached patch a cleaner patchSplinter Review
*** Bug 76009 has been marked as a duplicate of this bug. ***
Blocks: 75664
Need to test 31809 against this fix, last comment in that bug says this one
regressed it.
the 2 above patches are bogus, ignore them
Whiteboard: needed for 0.9 → needed for 0.9 - tested have r,sr need a=
Whiteboard: needed for 0.9 - tested have r,sr need a= → need4emb-0.9 - tested have r,sr need a=
[s]r=hyatt
i would prefer if this was made into a function since i'm sure we do this 
elsewhere, but i've been told not to taunt happy fun ball. r=pink.
a=drivers
Whiteboard: need4emb-0.9 - tested have r,sr need a= → need4emb-0.9 - tested have r,sr a=brendan - ready to check in
fixed
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.