Last Comment Bug 764555 - [devtb] Implement the style for the buttons in the developer toolbar
: [devtb] Implement the style for the buttons in the developer toolbar
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Firefox 16
Assigned To: Paul Rouget [:paul]
:
Mentors:
: 760446 (view as bug list)
Depends on: 763932
Blocks: 744906 764746 765564
  Show dependency treegraph
 
Reported: 2012-06-13 13:38 PDT by Paul Rouget [:paul]
Modified: 2012-07-06 04:01 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
mockup (86.51 KB, image/png)
2012-06-20 02:55 PDT, Paul Rouget [:paul]
no flags Details
screenshot work in progress (1.12 MB, image/png)
2012-06-22 04:04 PDT, Paul Rouget [:paul]
no flags Details
v1 (21.68 KB, patch)
2012-06-22 07:48 PDT, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review
v1.1 (22.50 KB, patch)
2012-06-25 03:22 PDT, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review
v1.1 (22.50 KB, patch)
2012-06-26 08:27 PDT, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review
v1.2 (25.64 KB, patch)
2012-06-26 09:02 PDT, Paul Rouget [:paul]
dao+bmo: review+
Details | Diff | Splinter Review

Description Paul Rouget [:paul] 2012-06-13 13:38:26 PDT
The latest mockup is: https://bug744906.bugzilla.mozilla.org/attachment.cgi?id=614521
Comment 1 Paul Rouget [:paul] 2012-06-20 02:55:19 PDT
Created attachment 634831 [details]
mockup

icons will come later
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-06-20 08:30:16 PDT
I think we're going to need to think about prompts. I think that having > for the console and >> for the command line is too subtle.

In an ideal world, I'd like to use { for the console (or anywhere that takes JavaScript) because { is the closest thing to how you start writing JS. But that could be confusing.

Maybe we should just use $ or something for commands.
Comment 3 Paul Rouget [:paul] 2012-06-22 04:04:30 PDT
Created attachment 635688 [details]
screenshot work in progress
Comment 4 Paul Rouget [:paul] 2012-06-22 07:48:04 PDT
Created attachment 635745 [details] [diff] [review]
v1

not test on linux and windows yet, but should be ok.
Comment 5 Paul Rouget [:paul] 2012-06-25 03:22:46 PDT
Created attachment 636262 [details] [diff] [review]
v1.1
Comment 6 Paul Rouget [:paul] 2012-06-25 03:31:33 PDT
Comment on attachment 636262 [details] [diff] [review]
v1.1

This patch includes 4 icons (in tools-icons-small.png). The debugger icon is not yet finished. So I used the WebConsole icon as a placeholder. This will be fixed in bug 760446.
Comment 7 Paul Rouget [:paul] 2012-06-26 08:27:17 PDT
Created attachment 636721 [details] [diff] [review]
v1.1

rebased
Comment 8 Paul Rouget [:paul] 2012-06-26 09:02:57 PDT
Created attachment 636730 [details] [diff] [review]
v1.2

debugger icon
Comment 9 Paul Rouget [:paul] 2012-06-26 10:08:34 PDT
*** Bug 760446 has been marked as a duplicate of this bug. ***
Comment 10 Paul Rouget [:paul] 2012-07-03 02:57:41 PDT
review ping
Comment 12 Tim Taubert [:ttaubert] 2012-07-06 04:01:28 PDT
https://hg.mozilla.org/mozilla-central/rev/650c5a98c137

Note You need to log in before you can comment on or make changes to this bug.