Last Comment Bug 765208 - IonMonkey: Increase maximum inlining depth
: IonMonkey: Increase maximum inlining depth
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
:
Mentors:
Depends on:
Blocks: IonSpeed
  Show dependency treegraph
 
Reported: 2012-06-15 05:29 PDT by Jan de Mooij [:jandem]
Modified: 2012-06-18 12:56 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (703 bytes, patch)
2012-06-15 05:29 PDT, Jan de Mooij [:jandem]
kvijayan: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2012-06-15 05:29:44 PDT
Created attachment 633486 [details] [diff] [review]
Patch

We need this for Kraken imaging-darkroom. On top of bug 762480 and bug 764923, this allows us to hoist a loop-invariant Math.log call in an inlined function.

As we discussed yesterday, we should also have some heuristics to limit the script size (and/or the total number of ops we inline), but since you're working on that I just went for the simplest fix here.
Comment 1 Kannan Vijayan [:djvj] 2012-06-18 08:38:24 PDT
Comment on attachment 633486 [details] [diff] [review]
Patch

Review of attachment 633486 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.  kraken-darkroom shows close to a 20% gain.
Comment 2 Jan de Mooij [:jandem] 2012-06-18 12:56:31 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/4a302a0e2eb3

Note You need to log in before you can comment on or make changes to this bug.