create_talos_zip.py points to github HEAD; should point to specific versions

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: k0scist, Assigned: wlach)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
http://mxr.mozilla.org/build/source/talos/create_talos_zip.py#19

mozhttpd, mozinfo, and mozdevice are all all taken from mozbase HEAD.
Instead we should point to specific versions.  Mobase has recently
gotten a tag-based versioning process:

https://wiki.mozilla.org/Auto-tools/Projects/MozBase#Versioning

We should ensure that the versions we need all have tags (potentially
bumping versions if they do not) and peg create_talos_zip.py to the
needed versions.  A versioning section should be written on
https://wiki.mozilla.org/Buildbot/Talos to inform programmers that
when a dependency is bumped in setup.py, it should also be bumped in
create_talos_zip.py

create_talos_zip.py could also be streamlined a bit. We want to get
rid of this and talos.zip entirely (bug 764588), but until that day we
will need to maintain this script.
Duplicate of this bug: 778228
(Reporter)

Comment 2

6 years ago
10:30 < wlach> jmaher: jhammel: this appears to work 
https://raw.github.com/mozilla/mozbase/mozdevice-0.9/mozdevice/mozdevice/devicemanager.py
Assignee: nobody → wlachance
Created attachment 669392 [details] [diff] [review]
Peg mozdevice version in talos to 0.9

So it looks like we might want to fix this sooner than later because the latest version of mozdevice breaks talos in production and the proposed fix in bug 797996 still seems to have some teething problems.

Here's a trivial patch to do what I suggested above, pegging talos to 0.9. I'm doing a try run here:

https://tbpl.mozilla.org/?tree=Try&rev=111f0fa6e393
Attachment #669392 - Flags: review?(jmaher)
(In reply to William Lachance (:wlach) from comment #3)
> Created attachment 669392 [details] [diff] [review]
> Peg mozdevice version in talos to 0.9
> 
> So it looks like we might want to fix this sooner than later because the
> latest version of mozdevice breaks talos in production and the proposed fix
> in bug 797996 still seems to have some teething problems.
> 
> Here's a trivial patch to do what I suggested above, pegging talos to 0.9.

s/talos/mozdevice.

Also, I didn't bother doing this for the other mozbase modules yet, leaving that for a followup patch after we've addressed the immediate issue.
(In reply to William Lachance (:wlach) from comment #3)

> I'm doing a try run here:
> 
> https://tbpl.mozilla.org/?tree=Try&rev=111f0fa6e393

This looks good. Two reds that appear to be unrelated to this change (fennec crashed and some desktop chrome problem).
Comment on attachment 669392 [details] [diff] [review]
Peg mozdevice version in talos to 0.9

Review of attachment 669392 [details] [diff] [review]:
-----------------------------------------------------------------

this looks good, so does try.
Attachment #669392 - Flags: review?(jmaher) → review+
http://hg.mozilla.org/build/talos/rev/8c97746f2eda
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Hmm, I'm not sure if I would completely resolve this bug yet, since we're still pulling mozinfo and mozhttpd from master. Should we peg those to specific versions as well?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
good point.
(Reporter)

Comment 10

6 years ago
I can finish the rest if there or not objections
(Reporter)

Comment 11

6 years ago
We should probably point the versions in setup.py to point to the same versions in create_talos_zip.py.  Then we will finally have *consistency* between the two
(In reply to Jeff Hammel [:jhammel] from comment #11)
> We should probably point the versions in setup.py to point to the same
> versions in create_talos_zip.py.  Then we will finally have *consistency*
> between the two

I think this is a great idea, even better if we can somehow only define the version numbers in one place.
Created attachment 669598 [details] [diff] [review]
Peg mozhttpd and mozinfo as well

Note that this won't work properly until we actually release and tag a new version of mozhttpd (v0.4): see bug 799541
(Reporter)

Comment 14

6 years ago
Created attachment 669633 [details] [diff] [review]
peg

tested locally
Attachment #669633 - Flags: review?(jmaher)
(Reporter)

Comment 15

6 years ago
Comment on attachment 669633 [details] [diff] [review]
peg

Beh, got the version wrong in setup.py
Attachment #669633 - Flags: review?(jmaher)
(Reporter)

Comment 16

6 years ago
Created attachment 669634 [details] [diff] [review]
peg for realz
Attachment #669633 - Attachment is obsolete: true
Attachment #669634 - Flags: review?(jmaher)
Comment on attachment 669634 [details] [diff] [review]
peg for realz

Review of attachment 669634 [details] [diff] [review]:
-----------------------------------------------------------------

this looks good.  It still hooks us up to github, but for the time being we can have concrete and repeatable talos.zip creations.
Attachment #669634 - Flags: review?(jmaher) → review+
(Reporter)

Comment 19

6 years ago
(In reply to Jeff Hammel [:jhammel] from comment #17)
> https://tbpl.mozilla.org/?tree=Try&rev=352948ae1c1a

Looks green enough to me
(Reporter)

Comment 21

6 years ago
filed a follow-up bug about ensuring the versions are the same between setup.py and create_talos_zip.py here bug 799754 ; closing
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.