Last Comment Bug 765388 - assertion: GL supports OES_EGL_image without supplying its functions.
: assertion: GL supports OES_EGL_image without supplying its functions.
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 762259 764972
Blocks: 728524
  Show dependency treegraph
 
Reported: 2012-06-15 15:09 PDT by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-08-14 08:16 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
-
15+


Attachments
patch (752 bytes, patch)
2012-06-15 15:09 PDT, Brad Lassey [:blassey] (use needinfo?)
jmuizelaar: review+
blassey.bugs: approval‑mozilla‑aurora-
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Review

Description Brad Lassey [:blassey] (use needinfo?) 2012-06-15 15:09:46 PDT
Created attachment 633692 [details] [diff] [review]
patch

I'm getting this assertion on every start up of a debug build. Joe suggested this change and it got rid of the assertion message.
Comment 1 Jeff Gilbert [:jgilbert] 2012-06-15 16:14:30 PDT
Comment on attachment 633692 [details] [diff] [review]
patch

Review of attachment 633692 [details] [diff] [review]:
-----------------------------------------------------------------

Please fix the typo, while you're here.
The assert for this should say "OES_EGL_image" not "ARB_sync".
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-06-18 11:56:07 PDT
Comment on attachment 633692 [details] [diff] [review]
patch

The patch looks fine with the change suggested by jgilbert.
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-06-18 15:02:44 PDT
(In reply to Jeff Gilbert [:jgilbert] from comment #1)
> Comment on attachment 633692 [details] [diff] [review]
> patch
> 
> Review of attachment 633692 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Please fix the typo, while you're here.
> The assert for this should say "OES_EGL_image" not "ARB_sync".

sorry for the confusion, copied the assertion from the code instead of the command line (since I had just fixed it) and wound up copying the wrong one.
Comment 4 Jeff Gilbert [:jgilbert] 2012-06-18 15:42:21 PDT
(In reply to Brad Lassey [:blassey] from comment #3)
> (In reply to Jeff Gilbert [:jgilbert] from comment #1)
> > Comment on attachment 633692 [details] [diff] [review]
> > patch
> > 
> > Review of attachment 633692 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > Please fix the typo, while you're here.
> > The assert for this should say "OES_EGL_image" not "ARB_sync".
> 
> sorry for the confusion, copied the assertion from the code instead of the
> command line (since I had just fixed it) and wound up copying the wrong one.

No, actually the bug name was correct (when it was filed), since there's was typo in the NS_ERROR in the code. The typo was fixed by bug 764972, so the new name is probably better to keep, going forward.
Comment 5 Jeff Gilbert [:jgilbert] 2012-06-18 15:42:57 PDT
Comment on attachment 633692 [details] [diff] [review]
patch

The nearby typo was fixed in bug 764972, so you're free to land this with no changes.
Comment 6 Ed Morley [:emorley] 2012-06-19 01:19:01 PDT
https://hg.mozilla.org/mozilla-central/rev/79a69b8095e0
Comment 7 Brad Lassey [:blassey] (use needinfo?) 2012-06-19 14:41:12 PDT
Comment on attachment 633692 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 1 day on m-c
Risk to taking this patch (and alternatives if risky): seemingly little, we were looking for the wrong symbol to load
String or UUID changes made by this patch:
Comment 8 Alex Keybl [:akeybl] 2012-06-19 20:25:23 PDT
Comment on attachment 633692 [details] [diff] [review]
patch

[Triage Comment]
Approving for Aurora, since we're considering for 14.0.1 inclusion.
Comment 9 Joe Drew (not getting mail) 2012-06-20 12:46:42 PDT
We won't have occasion to use this in 14, so it shouldn't be on beta.
Comment 10 Brad Lassey [:blassey] (use needinfo?) 2012-06-29 10:13:17 PDT
This code isn't on 15, so marking unaffected. Will clear the aurora approval as well.
Comment 11 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-07-24 11:27:48 PDT
Comment on attachment 633692 [details] [diff] [review]
patch

Required by bug 728524
Comment 12 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-07-24 12:10:53 PDT
We use EGLImage for the Flash patch (bug 687267), which we are trying to get into 15. Marking 15 affected.
Comment 13 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-24 12:14:04 PDT
Comment on attachment 633692 [details] [diff] [review]
patch

Thanks for updating the status, approving.
Comment 14 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-07-24 14:07:09 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/5569437d143d

Note You need to log in before you can comment on or make changes to this bug.