Last Comment Bug 762259 - Drop vendor suffixes from EGLImage for internal uses.
: Drop vendor suffixes from EGLImage for internal uses.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jeff Gilbert [:jgilbert]
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 774841
Blocks: 762265 765388 774059
  Show dependency treegraph
 
Reported: 2012-06-06 15:08 PDT by Jeff Gilbert [:jgilbert]
Modified: 2012-07-26 07:13 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (19.59 KB, patch)
2012-06-06 15:10 PDT, Jeff Gilbert [:jgilbert]
jacob.benoit.1: review+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Jeff Gilbert [:jgilbert] 2012-06-06 15:08:03 PDT
Generally we drop vendor suffixes when including extensions, but the original EGLImage patch left them in. We tend towards dropping them since they only add noise, since the suffixes don't tell us anything other than that they are from some sort of extension. ('was this one OES or KHR?'...)

We're going to be using this extension a bunch so it'd be nice to clean it up first.
Comment 1 Jeff Gilbert [:jgilbert] 2012-06-06 15:10:26 PDT
Created attachment 630733 [details] [diff] [review]
patch
Comment 3 Ed Morley [:emorley] 2012-06-13 05:58:51 PDT
https://hg.mozilla.org/mozilla-central/rev/50356ba76bbf
Comment 4 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-07-24 11:27:15 PDT
Comment on attachment 630733 [details] [diff] [review]
patch

[Approval Request Comment]
Required by bug 728524
Comment 5 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-24 12:07:56 PDT
Comment on attachment 630733 [details] [diff] [review]
patch

Approving supporting patches for bug 687267
Comment 6 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-07-24 14:07:47 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/2a236ea12ae5

Note You need to log in before you can comment on or make changes to this bug.