Last Comment Bug 765494 - Error: Microsoft.Live.Core.Internal is undefined in skydrive.live.com
: Error: Microsoft.Live.Core.Internal is undefined in skydrive.live.com
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: DOM (show other bugs)
: 14 Branch
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 736731
Blocks: 687579
  Show dependency treegraph
 
Reported: 2012-06-16 09:07 PDT by Alice0775 White
Modified: 2012-07-11 13:34 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alice0775 White 2012-06-16 09:07:50 PDT
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/131961e5e0d1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120612030527

When I test Bug 763593,
Error: Microsoft.Live.Core.Internal is undefined in skydrive.live.com

Steps to Reproduce:
1. Open Error Console
2. Open https://skydrive.live.com/?cid=654125A09BEBAF67&id=654125A09BEBAF67!245

Actual Results:
Error: Microsoft.Live.Core.Internal is undefined
Source file: https://secure.wlxrs.com/_D/F$Live.SiteContent.Messenger/4.4.1585/release/Microsoft.Live.Messenger.Services.Loader.js
Line: 149

Expected Results:
 No error


Regression window(m-c),
Works:
http://hg.mozilla.org/mozilla-central/rev/ed57abebd328
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120303 Firefox/13.0a1 ID:20120303051507
Fails:
http://hg.mozilla.org/mozilla-central/rev/baec1efc87a4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120303 Firefox/13.0a1 ID:20120303164007
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ed57abebd328&tochange=baec1efc87a4


Regression window(m-i),
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d43c3e308c82
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120302 Firefox/13.0a1 ID:20120303052207
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7c62688f88fa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120303 Firefox/13.0a1 ID:20120303053807
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d43c3e308c82&tochange=55e360715d76

Triggered by:
8cdce56098cd	Matheus Kerschbaum — Bug 687579 part 1: Remove globalStorage implementation. r=jst Bug 687579 part 1: Remove globalStorage implementation. r=jst
Comment 1 Loic 2012-06-16 09:28:13 PDT
Looks like similar to Hotmail's bug 736731 (same regression). :)
Comment 2 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-06-18 09:24:17 PDT
Raul, could you guys take a look at this, please?
Comment 3 Raul D @ Yahoo! 2012-06-18 19:10:28 PDT
Will take a look.
Comment 4 j.j. 2012-06-28 11:34:18 PDT
Can't reproduce in Nightly, seems to be fixed by Microsoft. See bug 736731 comment 37
Comment 5 j.j. 2012-07-11 13:34:21 PDT
let's assume it's FIXED since no-one disagreed with comment 4

Note You need to log in before you can comment on or make changes to this bug.