Allow the webapps registry to be safely shared across multiple concurrent processes

RESOLVED WONTFIX

Status

Core Graveyard
DOM: Apps
RESOLVED WONTFIX
6 years ago
7 months ago

People

(Reporter: Mardak, Unassigned)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-kilimanjaro:+, firefox16-)

Details

(Whiteboard: [Desktop WebRT])

(Reporter)

Description

6 years ago
From bug 738832:

(In reply to Myk Melez [:myk] [@mykmelez] from comment #20)
> We need to make it possible for multiple processes to safely share a single
> registry while continuing to make it possible for B2G to provision new
> profiles.

The particular use case is an active Firefox and native runtime (perhaps of a Marketplace app) both need to reference and modify the webapps registry. Right now because it's cached in memory, changes in one place does not reflect in the other. And there's potential for data loss if both Firefox and the runtime try to modify and save their changes.
I have a longish term goal to move the current file-based storage to indexedDB. I'm not sure if we support concurrent writers to the same db in this context, but that may be worth trying.

Updated

6 years ago
Blocks: 738816
k9o nomination - this is required to be implemented for marketplace to operate correctly as a web app with installs allowed from the marketplace app and fennec native.
blocking-kilimanjaro: --- → ?

Updated

6 years ago
Blocks: 766259

Updated

6 years ago
blocking-kilimanjaro: ? → +
I'm confused by what this bug is asking for. Can someone clarify the use case? Is this needed for mobile still? Do we just need to move webapps.sqlite to the profile root dir? Do we want to do that?
(Reporter)

Comment 4

6 years ago
(In reply to Wesley Johnston (:wesj) from comment #3)
> I'm confused by what this bug is asking for.
Added concurrent to the title to clarify. This bug is for running instances of Firefox and an app, and both want to read and modify the registry.
Summary: Allow the webapps registry to be safely shared across multiple processes → Allow the webapps registry to be safely shared across multiple concurrent processes

Updated

6 years ago
No longer blocks: 766259

Updated

6 years ago
Whiteboard: [Android WebRT], [Desktop WebRT}

Updated

6 years ago
Whiteboard: [Android WebRT], [Desktop WebRT} → [Android WebRT], [Desktop WebRT]

Updated

6 years ago
Blocks: 746465
Not a blocker to release web runtime on desktop, but it's a want, as fixing this will allow us to have a marketplace app on desktop that works correctly. Flagging for tracking-firefox16.
tracking-firefox16: --- → ?

Comment 6

6 years ago
If this doesn't block the feature, no need to track. We'd definitely consider taking an uplift if/when ready, however.
tracking-firefox16: ? → -

Updated

6 years ago
No longer blocks: 746465
Component: DOM: Mozilla Extensions → DOM: Apps
Talking with Wes, this problem will likely be rate on Android. Possibly less rare on desktop, but still rare.
Whiteboard: [Android WebRT], [Desktop WebRT] → [Desktop WebRT]

Updated

6 years ago
Duplicate of this bug: 790401

Updated

6 years ago
Blocks: 790401
Per bug 1238576, we're going to stop exposing navigator.mozApps on desktop/Android (except where MOZ_B2G is set, such as B2G Desktop), so we won't fix this bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Updated

7 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.