Closed Bug 765941 Opened 7 years ago Closed 7 years ago

[tablet] Thumbnail doesn't update after following a links to an HTTP redirect

Categories

(Firefox for Android :: General, defect)

16 Branch
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 16
Tracking Status
firefox15 --- verified
firefox16 --- verified

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

Details

(Whiteboard: [tablet])

Attachments

(1 file)

I noticed this while working on bug 765805, but it turns out to be a problem even without those patches.  Steps to reproduce:

1. In native Fennec on a tablet, open http://limpet.net/mbrubeck/
2. Open the tab sidebar.
3. Tap on the "Mozilla" link in the first paragraph on the page.

Expected results: http://www.mozilla.org/en-US/firefox/fx/ opens.

Actual results:  http://www.mozilla.org/en-US/firefox/fx/ opens but the tab thumbnail does not update.

This happens because GeckoApp.handleDocumentStop compares the URI from the StateChange message to the URI from the LocationChange message.  However, the StateChange message uses the originalURI, so this breaks when there is a redirect.
No longer blocks: 739407
Attached patch patchSplinter Review
What we really want to do here is make sure the same document is still loaded once the timeout fires.  Instead of comparing the URI we get from the StateChange message, we should just get the URI from the tab before and after.
Attachment #634221 - Flags: review?(bnicholson)
Comment on attachment 634221 [details] [diff] [review]
patch

Should the uri parameter be removed from handleDocumentStop since it is no longer used?
Attachment #634221 - Flags: review?(bnicholson) → review+
Comment on attachment 634221 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 739407
User impact if declined: Thumbnails in tab sidebar show the wrong page after navigating to certain URLs.
Testing completed (on m-c, etc.): Landed on inbound June 19
Risk to taking this patch (and alternatives if risky): Very low-risk two-line mobile-only fix.
String or UUID changes made by this patch: None.

(In reply to Brian Nicholson (:bnicholson) from comment #2)
> Should the uri parameter be removed from handleDocumentStop since it is no
> longer used?

Good idea; done.

https://hg.mozilla.org/integration/mozilla-inbound/rev/1a2aa554c055
Attachment #634221 - Flags: approval-mozilla-aurora?
Comment on attachment 634221 [details] [diff] [review]
patch

[Triage Comment]
Tablet UI bugs are approved for Aurora 15, as they carry little risk to mobile and none to desktop.
Attachment #634221 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/1a2aa554c055
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Depends on: 766867
Whiteboard: [tablet]
Verified/fixed on:
Nightly Fennec 16.0a1 (2012-07-11)
Aurora Fennec 15.0a2 (2012-07-11)
Using:
Samsung Galaxy Tab (3.1)

The tab thumbnail is updated now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.