java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java)

RESOLVED FIXED in Firefox 15

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Scoobidiver (away), Assigned: bnicholson)

Tracking

({crash, regression, topcrash})

15 Branch
Firefox 16
ARM
Android
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(firefox15+ fixed)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
There's one crash in 16.0a1/20120620: bp-b95cce3b-8a1f-4a7c-830d-808f42120620.

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java:1348)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:132)
	at org.mozilla.gecko.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.GeckoApp%2423.run%28GeckoApp.java%29
(Reporter)

Updated

5 years ago
Crash Signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java)] → [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java) ]
(Reporter)

Comment 1

5 years ago
There are currently 9 crashes. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=373e6f9264e6&tochange=c3190d715044
Keywords: regression
(Reporter)

Comment 2

5 years ago
The Aurora regression range is:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=e5f9e8f2816f&tochange=d557426b0c8d
It's likely a regression from bug 765941.
Blocks: 765941
Crash Signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java) ] → [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java) ] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$36.run(GeckoApp.java) ]
status-firefox15: --- → affected
Version: Firefox 16 → Firefox 15
(Reporter)

Updated

5 years ago
Crash Signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java) ] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$36.run(GeckoApp.java) ] → [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java) ] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$36.run(GeckoApp.java) ] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$24.…
(Reporter)

Comment 3

5 years ago
It's #6 top crasher in 15.a2 over the last 3 days.
tracking-fennec: --- → ?
Keywords: topcrash
(Assignee)

Comment 4

5 years ago
Created attachment 636945 [details] [diff] [review]
Check if oldURL is null

tab.getURL() can return null; this NPE likely thrown when we call oldURL.equals().
Assignee: nobody → bnicholson
Attachment #636945 - Flags: review?(mbrubeck)
Comment on attachment 636945 [details] [diff] [review]
Check if oldURL is null

Hmm... if getURL returns null both times, should we run the delayed stuff or not?  Are there steps to reproduce this?

r+ because this fixes the crash and returns us to the previous behavior, but I'm curious if there's something better we should do here.
Attachment #636945 - Flags: review?(mbrubeck) → review+
(Assignee)

Comment 6

5 years ago
Created attachment 636963 [details] [diff] [review]
Use null-safe string comparison for oldURL

(In reply to Matt Brubeck (:mbrubeck) from comment #5)
> Comment on attachment 636945 [details] [diff] [review]
> Check if oldURL is null
> 
> Hmm... if getURL returns null both times, should we run the delayed stuff or
> not?  Are there steps to reproduce this?
> 
> r+ because this fixes the crash and returns us to the previous behavior, but
> I'm curious if there's something better we should do here.

You're right - this wasn't the best approach. We shouldn't bail if oldURL is null since the new URL may be valid. In fact, even if the new URL is null, I assume it's still okay to take a screenshot, but I can't verify this. I've hit this NPE a few times today when I play around with the tabs tray (creating and removing tabs), but I don't have reliable STR.
Attachment #636945 - Attachment is obsolete: true
Attachment #636963 - Flags: review?(mbrubeck)
(Assignee)

Comment 7

5 years ago
Bleh, sorry...got confused. We *don't* take the screenshot if they aren't equal. This patch makes it so that we *do* take the screenshot if it's null both times, which I hope is fine. I'll play around with the tabs tray to make sure I can't reproduce the crash again.
Attachment #636963 - Flags: review?(mbrubeck) → review+
(Assignee)

Comment 8

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/2791940fb1ff
https://hg.mozilla.org/mozilla-central/rev/2791940fb1ff
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
(Reporter)

Comment 10

5 years ago
It's #3 top crasher in 15.0a2.
(Assignee)

Comment 11

5 years ago
Comment on attachment 636963 [details] [diff] [review]
Use null-safe string comparison for oldURL

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 765941
User impact if declined: potential crash on redirects
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): very low risk
String or UUID changes made by this patch: none
Attachment #636963 - Flags: approval-mozilla-aurora?
(Reporter)

Updated

5 years ago
Crash Signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java) ] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$36.run(GeckoApp.java) ] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$24.… → [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java) ] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$36.run(GeckoApp.java) ] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$24.…

Updated

5 years ago
tracking-firefox15: --- → +

Updated

5 years ago
Attachment #636963 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 12

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/fc5fcbb7d152
status-firefox15: affected → fixed
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.