when replying to existing email message format is plain text

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: carl, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

I went into sent directory and clicked on reply to an email message


Actual results:

the format of the compose window, replied to message, was plain text


Expected results:

It should be in html, not plain text.  I have it set on every email account to use html instead of plain text.

This does not happen if I click on the write button to start a new email message, that compose window is in html format, not plain text.

I do have thunderbird set to send both types of email.
(Reporter)

Comment 1

6 years ago
I know the email message is in plain text format because the formatting toolbar is not there.

Comment 2

6 years ago
(In reply to Carl from comment #0)
The message you are replying to is in HTML or text?
(Reporter)

Comment 3

6 years ago
The message is in HTML that I am replying to.

Comment 4

6 years ago
(In reply to Carl from comment #3)
> The message is in HTML that I am replying to.

WFM. When I reply to an HTML message, an HTML reply is generated.
User Agent: Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20120614 Thunderbird/13.0.1
Application Build ID: 20120614161456
(Reporter)

Comment 5

6 years ago
This happens to messages in the sent folder only.  Outside of it, all other folders work as they should when replying to messages.

Comment 6

6 years ago
Joe, does this reproduce for you?

Comment 7

6 years ago
I cannot reproduce with current trunk
(Reporter)

Comment 8

6 years ago
I am still getting this on thunderbird 17.0.2.  I will test this again when version 18 is released.
Version: 13 → 17

Comment 9

5 years ago
(In reply to Carl from comment #5)
> This happens to messages in the sent folder only.  Outside of it, all other
> folders work as they should when replying to messages.

Did you by any chance set your own domain to receive text-only messages? In TB settings -> Compose -> Sending Options, or for your own contact in one of your address books? Because your problem occurs when you basically respond to yourself (i.e. to your own e-mails in the sent folder).
(Reporter)

Comment 10

5 years ago
Hi,

I did not set that option.  I have it set to send both html and plain text emails.

The email is also not in my address book.

Comment 11

2 years ago
I also cannot reproduce.

Carl, do you still see this?
Flags: needinfo?(carl)
Whiteboard: [closeme 2017-01-15]
(Reporter)

Comment 12

2 years ago
Hi,

I am no longer experiencing this issue.
Flags: needinfo?(carl)

Comment 13

2 years ago
Thanks Carl
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2017-01-15]
You need to log in before you can comment on or make changes to this bug.