[adbe 3226428] Taking a speed test on YouTube hangs Firefox

RESOLVED FIXED

Status

External Software Affecting Firefox
Flash (Adobe)
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: alindeac, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [flash-11.3])

Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0
Adobe Flash Player 11,3,300,257

If the item "Take speed test" is selected while in Full Screen, Firefox hangs. 

Reproducible: always

Steps to reproduce:
1. Navigate to YouTube and select any video
2. Click on the "Full Screen" button
3. While in full screen mode, right click on the video and from the context menu select "Take speed test" item.

Expected results:
Full screen mode will be exited and a new tab "Youtube Broadcast Yourself" opens.

Actual results:
Full screen mode is exited, but the flash content is black and after that Firefox hangs.
If I disable the protected mode the hang is not reproducible. (http://forums.adobe.com/thread/1018071?tstart=0)
The hang doesn't occur with the Flash protected mode disabled on: Firefox 4.0.1, 5.0.1, 6.0.2, 7.0.1, 8.0.1, 9.0.1, 10.0.2, 11, 12 and 13.0.1.

If I don't disable the protected mode then the issue is reproducible on Firefox 9.0.1, 10.0.2, 11, 12 and 13.0.1. On all the other versions (from 4.0.1 to 8.0.1) the flash content doesn't load, even if Real Player is not installed.

Comment 2

6 years ago
Sal - can we open a bug for this on the Adobe side since this is related to protected mode?
Whiteboard: [flash-11.3]

Comment 3

6 years ago
yes, we are tracking internally in #3226428.  thanks for the STR, it reproduces consistently...
Status: NEW → ASSIGNED

Updated

6 years ago
Summary: Taking a speed test on YouTube hangs Firefox → [adbe 3226428] Taking a speed test on YouTube hangs Firefox
(In reply to smadayag from comment #3)
> yes, we are tracking internally in #3226428.  thanks for the STR, it
> reproduces consistently...

I'm not finding a bug at https://bugbase.adobe.com/index.cfm?event=bug&id=3226428 - can you confirm the bug number Adobe is using to track this?

Comment 5

6 years ago
#3226428 would be an internal bug number.  if you'd like, create a public bug at bugbase.adobe.com and let me know...  i can bug group them.  thanks.

Updated

5 years ago
Duplicate of this bug: 783937

Comment 7

5 years ago
Additional information partially copy and pasted from Bug 783937:

If the video is not viewed full screen, the video is paused and the YouTube speed test pops up in a new tab, as it should.
BUT, if the video is made full screen, attempting to take the speed test freezes Firefox.

Either the YouTube speed test should pop up without freezing Firefox, but regardless of whether the video is full screen; or if a bug in Adobe Flash makes this impossible, Firefox should complain that something went wrong with Adobe Flash and recover gracefully from the problem (as it seems to be able to do when the "Plugin Container" crashes).

Google Chrome 21.0.1180.79 m handles this almost properly -- it can give a blank screen after closing the YouTube speed test tab (which pops up without a problem), but it doesn't freeze, and it can get back to the video after Alt-Tabbing away and back, so not 100% of the problem is with Adobe Flash.

This might be related to bug 776219, but I don't have 2 monitors so I can't test that one, and that bug has no mention of this particular problem.

Comment 8

5 years ago
our internal bug has been closed fixed in our 11.4 dev builds 8/8.  this bug should be resolved in the upcoming 11.4 Dolores release tonight/tomorrow.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.