Last Comment Bug 766666 - GLContext.cpp:2955:14: error: variable ‘found’ set but not used [-Werror=unused-but-set-variable]
: GLContext.cpp:2955:14: error: variable ‘found’ set but not used [-Werror=unus...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla16
Assigned To: Daniel Holbert [:dholbert]
:
:
Mentors:
Depends on:
Blocks: buildwarning 705665
  Show dependency treegraph
 
Reported: 2012-06-20 12:00 PDT by Daniel Holbert [:dholbert]
Modified: 2012-06-21 04:05 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (704 bytes, patch)
2012-06-20 12:12 PDT, Daniel Holbert [:dholbert]
jacob.benoit.1: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2012-06-20 12:00:33 PDT
In my m-c build with GCC 4.6 and --enable-warnings-as-errors:
{
GLContext.cpp:2955:14: error: variable ‘found’ set but not used [-Werror=unused-but-set-variable]
cc1plus: all warnings being treated as errors
}

(Looks like this warning already existed, but its directory is now included in the "FAIL_ON_WARNINGS" umbrella as of bug 765989.  (And GCC 4.6 is newer & has a few more warnings than our builders' GCC versions, which is why this didn't cause trouble on TBPL.)
Comment 1 Daniel Holbert [:dholbert] 2012-06-20 12:10:14 PDT
(Looks like bug 705665 removed the last usage of this variable, FWIW -- so that's when this warning appeared.)
Comment 2 Daniel Holbert [:dholbert] 2012-06-20 12:12:19 PDT
Created attachment 635001 [details] [diff] [review]
fix
Comment 3 Daniel Holbert [:dholbert] 2012-06-20 12:40:57 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/01d31319cfdd
Comment 4 Ed Morley [:emorley] 2012-06-21 04:05:28 PDT
https://hg.mozilla.org/mozilla-central/rev/01d31319cfdd

Note You need to log in before you can comment on or make changes to this bug.