Last Comment Bug 766843 - Menu no longer renders in Firefox
: Menu no longer renders in Firefox
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 16 Branch
: x86 All
: -- normal (vote)
: mozilla16
Assigned To: :Ehsan Akhgari (busy, don't ask for review please)
:
Mentors:
Depends on: 769362
Blocks: 157681
  Show dependency treegraph
 
Reported: 2012-06-20 21:33 PDT by mdew
Modified: 2012-06-28 10:53 PDT (History)
7 users (show)
ehsan: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
test.rar (88.05 KB, application/x-rar-compressed)
2012-06-20 21:33 PDT, mdew
no flags Details
Minimized test case (sort of) (16.95 KB, text/html)
2012-06-27 12:48 PDT, :Ehsan Akhgari (busy, don't ask for review please)
no flags Details
Patch (v1) (4.47 KB, patch)
2012-06-27 13:24 PDT, :Ehsan Akhgari (busy, don't ask for review please)
bzbarsky: review+
Details | Diff | Review
Patch with updated comment (4.64 KB, patch)
2012-06-27 13:30 PDT, :Ehsan Akhgari (busy, don't ask for review please)
no flags Details | Diff | Review

Description mdew 2012-06-20 21:33:05 PDT
Created attachment 635183 [details]
test.rar

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/16.0 Firefox/16.0a1
Build ID: 20120606221720

Steps to reproduce:

This is an internal, private site, so its a site rip.. I stripped a bit of site, but needs a better test case.


Actual results:

Extract files, open the htm file,
Menu dropdowns don't render

Working: 1339046240 (06-Jun-2012 22:37)
Broken: 1339061779 (07-Jun-2012 04:02)


Expected results:

Menu dropdown should render
Comment 1 Alice0775 White 2012-06-20 22:10:15 PDT
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c29b842c4159
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120606221720
Bad:
http://hg.mozilla.org/mozilla-central/rev/3933384d8315
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120607023619
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c29b842c4159&tochange=3933384d8315

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f5a441d6929f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120605210720
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/df6702c41ddd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120605215419
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f5a441d6929f&tochange=df6702c41ddd

Triggered by: Bug 157681
Comment 2 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-27 12:48:46 PDT
Created attachment 637222 [details]
Minimized test case (sort of)

This happens with a relatively positioned table element, where the top is modified dynamically.  This test should scroll up the div by 50px, but it gets it wrong.
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-27 13:24:50 PDT
Created attachment 637232 [details] [diff] [review]
Patch (v1)
Comment 4 Boris Zbarsky [:bz] 2012-06-27 13:26:22 PDT
Comment on attachment 637232 [details] [diff] [review]
Patch (v1)

Please make the comment say _why_ we're not processing them (because normally position on the inner table is ignored during reflow).

r=me with that.
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-27 13:30:54 PDT
Created attachment 637234 [details] [diff] [review]
Patch with updated comment
Comment 6 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-27 13:31:21 PDT
http://tbpl.mozilla.org/?tree=Try&rev=a78f4fe81951
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-27 20:52:44 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/614d3cf8947b
Comment 8 Ed Morley [:emorley] 2012-06-28 01:07:33 PDT
https://hg.mozilla.org/mozilla-central/rev/614d3cf8947b

Note You need to log in before you can comment on or make changes to this bug.