Closed Bug 766861 Opened 7 years ago Closed 7 years ago

java.lang.NullPointerException: at org.mozilla.gecko.BrowserApp.onPrepareOptionsMenu(BrowserApp.java) at android.app.Activity.onPreparePanel(Activity.java) on Gingerbread

Categories

(Firefox for Android :: General, defect, critical)

16 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 773089

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression, topcrash, Whiteboard: [native-crash])

Crash Data

It's similar to bug 760357 but it's BrowserApp instead of GeckoApp.
There are 6 crashes from 2 users in 16.0a1/20120620065138 including bp-7161d8f4-2c53-4d91-930c-f54be2120620.

The regression range might be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=373e6f9264e6&tochange=c3190d715044
It might caused by bug 762727.

java.lang.NullPointerException
	at org.mozilla.gecko.BrowserApp.onPrepareOptionsMenu(BrowserApp.java:586)
	at android.app.Activity.onPreparePanel(Activity.java:2174)
	at org.mozilla.gecko.GeckoApp.onPreparePanel(GeckoApp.java:603)
	at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java:332)
	at com.android.internal.policy.impl.PhoneWindow.onKeyDownPanel(PhoneWindow.java:568)
	at com.android.internal.policy.impl.PhoneWindow.onKeyDown(PhoneWindow.java:1210)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.dispatchKeyEvent(PhoneWindow.java:1668)
	at android.view.ViewRoot.deliverKeyEventToViewHierarchy(ViewRoot.java:2568)
	at android.view.ViewRoot.handleFinishedEvent(ViewRoot.java:2543)
	at android.view.ViewRoot.handleMessage(ViewRoot.java:1868)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:123)
	at android.app.ActivityThread.main(ActivityThread.java:3647)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:839)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:597)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.BrowserApp.onPrepareOptionsMenu%28BrowserApp.java%29
Crash Signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.BrowserApp.onPrepareOptionsMenu(BrowserApp.java)] → [@ java.lang.NullPointerException: at org.mozilla.gecko.BrowserApp.onPrepareOptionsMenu(BrowserApp.java) ]
It's #7 top crasher in 16.0a1.
Keywords: topcrash
There's a spike in crashes from 16.0a1/20120711. The regression range for the spike is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=02b26fb307b4&tochange=53860f11100c
It might be a regression from bug 769454 or bug 769237.
tracking-fennec: --- → ?
Summary: java.lang.NullPointerException: at org.mozilla.gecko.BrowserApp.onPrepareOptionsMenu(BrowserApp.java) at android.app.Activity.onPreparePanel(Activity.java) → java.lang.NullPointerException: at org.mozilla.gecko.BrowserApp.onPrepareOptionsMenu(BrowserApp.java) at android.app.Activity.onPreparePanel(Activity.java) on Gingerbread
The spike is so big that it accounts for 20% of crashes over the last day.
Sriram?
Crashes stopped after 16.0a1/20120712. The working range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=46804c31366b&tochange=6489be1890c0
It's fixed by bug 773089.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 773089
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.