worker api to create service window

RESOLVED DUPLICATE of bug 774506

Status

()

Firefox
SocialAPI
--
critical
RESOLVED DUPLICATE of bug 774506
6 years ago
5 years ago

People

(Reporter: markh, Assigned: Michael Hanson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fx17])

(Reporter)

Description

6 years ago
If the provider's sidebar is closed but their worker notices a new chat message, the worker should be able to arrange for a service (chat) window to be opened.

critical, but not a blocker, as Amigo would like it sooner rather than later :)
it would have to be limited to only the current provider.  As well, there are abuse scenarios here, especially while the service window is a top level window.  It would be better to see the status indicators in the toolbar update to let the user know a chat request has been made, let the user open the chat.
Assignee: nobody → mhanson
Whiteboard: [ms1]

Updated

6 years ago
Whiteboard: [ms1] → [Fx16]
there is a thread on the email list about this, it seems to be leaning towards not allowing the worker to open any windows, and relying on status icons/panels.  We need a quick decision.

Updated

6 years ago
Whiteboard: [Fx16] → [Fx17]
notifications in bug 774506 provides a mechanism for the worker to let the user respond to chat requests
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 774506
You need to log in before you can comment on or make changes to this bug.