Last Comment Bug 766975 - xpcshell.o deps get clobbered on Unix platforms
: xpcshell.o deps get clobbered on Unix platforms
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
-- normal (vote)
: mozilla16
Assigned To: Mike Hommey [:glandium]
:
: Gregory Szorc [:gps] (away until 2017-03-20)
Mentors:
: 767422 (view as bug list)
Depends on: 785622
Blocks: 763893
  Show dependency treegraph
 
Reported: 2012-06-21 07:52 PDT by Bobby Holley (:bholley) (busy with Stylo)
Modified: 2012-08-25 06:33 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Rename OBJS-related dependency files (1.79 KB, patch)
2012-06-21 11:25 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Rename OBJS-related dependency files (6.10 KB, patch)
2012-06-21 11:44 PDT, Mike Hommey [:glandium]
khuey: review+
Details | Diff | Splinter Review

Description User image Bobby Holley (:bholley) (busy with Stylo) 2012-06-21 07:52:11 PDT
I revved the IID, and xpcshell is failing on tinderbox when it tries to get nsIXPConnect, and needs a clobber.

I don't know how to do this properly. Maybe khuey can help?
Comment 2 User image Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-21 09:10:27 PDT
Whatever you're seeing is something else.  xpcshell does depend on nsIXPConnect.h.
Comment 3 User image Ed Morley [:emorley] 2012-06-21 09:11:32 PDT
Why did we have to clobber then?

I'd like to stamp out these have to force clobber type issues ideally...
Comment 4 User image Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-21 09:13:10 PDT
So would I, but as filed, the bug is invalid.  If we can reproduce this locally, then lets file another bug and investigate.
Comment 5 User image Bobby Holley (:bholley) (busy with Stylo) 2012-06-21 09:14:39 PDT
I still see this locally on mac.

STR:
1 - do a clean build
2 - rev the UUID of nsIXPConnect
3 - do a top-level make

Kyle, did you maybe give the build too many hints with your make -C?
Comment 6 User image Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-21 09:15:23 PDT
No.  I did a top level make.

Can you attach objdir/js/xpconnect/shell/.deps/xpcshell.o.pp?
Comment 7 User image Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-21 09:16:19 PDT
Also, are you using gcc or clang?
Comment 8 User image Bobby Holley (:bholley) (busy with Stylo) 2012-06-21 09:19:53 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #6)
> No.  I did a top level make.
> 
> Can you attach objdir/js/xpconnect/shell/.deps/xpcshell.o.pp?

There is no xpcshell.o.pp. There is, however, xpcshell.pp:

xpcshell : xpcshell.o xpcshellMacUtils.o ../../../dist/lib/libxpcomglue_s.a ../../../dist/bin/XUL ../../../dist/bin/XUL

(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #7)
> Also, are you using gcc or clang?

gcc.
Comment 9 User image Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-21 09:22:36 PDT
Uh .... why on earth is there no xpcshell.o.pp?
Comment 10 User image Bobby Holley (:bholley) (busy with Stylo) 2012-06-21 09:56:15 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #9)
> Uh .... why on earth is there no xpcshell.o.pp?

You tell me. I have no idea what a pp file is.
Comment 11 User image Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-21 09:59:01 PDT
It's the compiler generated dependency file.

If you make clean in js/xpconnect/shell and then make, what command is used to build xpcshell.o?
Comment 12 User image Bobby Holley (:bholley) (busy with Stylo) 2012-06-21 10:03:50 PDT
http://pastebin.mozilla.org/1669612
Comment 13 User image Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-21 10:06:21 PDT
Fun.
Comment 14 User image Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-21 10:08:47 PDT
So, what happens here is that a set of deps are generated for xpcshell (the binary), which overwrite the set of deps for xpcshell.o.  This doesn't happen on Windows, since there we use the object suffix in the deps file.
Comment 15 User image Ted Mielczarek [:ted.mielczarek] 2012-06-21 10:17:02 PDT
Fallout from one of glandium's patches but I forget which one.
Comment 16 User image Mike Hommey [:glandium] 2012-06-21 11:21:25 PDT
Ah, that'd be a fallout from bug 763893
Comment 17 User image Mike Hommey [:glandium] 2012-06-21 11:25:22 PDT
Created attachment 635388 [details] [diff] [review]
Rename OBJS-related dependency files
Comment 18 User image Mike Hommey [:glandium] 2012-06-21 11:44:33 PDT
Created attachment 635397 [details] [diff] [review]
Rename OBJS-related dependency files

This should actually work.
Comment 19 User image Ed Morley [:emorley] 2012-06-22 09:20:44 PDT
*** Bug 767422 has been marked as a duplicate of this bug. ***
Comment 21 User image Ryan VanderMeulen [:RyanVM] 2012-06-23 05:46:48 PDT
https://hg.mozilla.org/mozilla-central/rev/a13e11be0959

Note You need to log in before you can comment on or make changes to this bug.