Some files are always rebuilt during incremental builds because of dangling .pp files

RESOLVED FIXED in mozilla18

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla18
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Since bug 766975 landed, people have had dangling .pp files in the .deps directories in the objdir, and as a result, their incremental build have been rebuilding some files even when rebuilding them was not required. This results in extra time waiting for builds.
(Assignee)

Comment 1

5 years ago
Created attachment 655331 [details] [diff] [review]
Only include .pp files corresponding to files we do build

The cl.py changes are due to the fact that we were actually not storing the .pp file in the right directory when the object file name contains a path (such as when building libjpeg). This makes the behaviour match that of unix builds.

I checked that all the .pp files we generate during a clobber build are included this way, and media/libvpx and js/xpconnect/src are the only places where we have custom-generated files that generate .pp files that aren't included in the variables I added, so they are now in an extra variable.
Attachment #655331 - Flags: review?(khuey)
(Assignee)

Updated

5 years ago
Blocks: 462463
(Assignee)

Updated

5 years ago
Duplicate of this bug: 779268
Attachment #655331 - Flags: review?(khuey) → review+
(Assignee)

Updated

5 years ago
Assignee: nobody → mh+mozilla
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c2e464e9524b

Comment 4

5 years ago
https://hg.mozilla.org/mozilla-central/rev/c2e464e9524b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.