Last Comment Bug 767264 - remove uses of do_QueryObject() in CAccessibleHyperlink
: remove uses of do_QueryObject() in CAccessibleHyperlink
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Mark Capella [:capella]
:
Mentors:
: 741702 (view as bug list)
Depends on:
Blocks: cleana11y
  Show dependency treegraph
 
Reported: 2012-06-21 22:24 PDT by Trevor Saunders (:tbsaunde)
Modified: 2012-10-07 16:40 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (8.86 KB, patch)
2012-06-22 02:27 PDT, Mark Capella [:capella]
no flags Details | Diff | Review
Patch (v2) (8.86 KB, patch)
2012-06-22 05:36 PDT, Mark Capella [:capella]
tbsaunde+mozbugs: review+
Details | Diff | Review
Patch (v3) (8.81 KB, patch)
2012-06-22 20:27 PDT, Mark Capella [:capella]
dbolter: review+
Details | Diff | Review

Description Trevor Saunders (:tbsaunde) 2012-06-21 22:24:18 PDT
same as bugs 762394 accept you sttic cast to AccessibleWrap*
Comment 1 Mark Capella [:capella] 2012-06-22 02:27:39 PDT
Created attachment 635671 [details] [diff] [review]
Patch (v1)

First / quick try at this ....
Comment 2 Mark Capella [:capella] 2012-06-22 05:36:58 PDT
Created attachment 635706 [details] [diff] [review]
Patch (v2)

Bah ... missed several nits...
Comment 3 Trevor Saunders (:tbsaunde) 2012-06-22 17:22:28 PDT
Comment on attachment 635706 [details] [diff] [review]
Patch (v2)

/src/msaa/ia2AccessibleHyperlink.cpp
>rename from accessible/src/msaa/CAccessibleHyperlink.cpp
>rename to accessible/src/msaa/ia2AccessibleHyperlink.cpp
>--- a/accessible/src/msaa/CAccessibleHyperlink.cpp
>+++ b/accessible/src/msaa/ia2AccessibleHyperlink.cpp
>@@ -1,53 +1,53 @@
> /* -*- Mode: C++; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
> /* vim:expandtab:shiftwidth=2:tabstop=2:
>  */
> /* This Source Code Form is subject to the terms of the Mozilla Public
>  * License, v. 2.0. If a copy of the MPL was not distributed with this
>  * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
> 
>-#include "CAccessibleHyperlink.h"
>+#include "ia2AccessibleHyperlink.h"
> 
> #include "Accessible2.h"
> #include "AccessibleHyperlink.h"
> #include "AccessibleHyperlink_i.c"
> 
> #include "AccessibleWrap.h"
> #include "nsIWinAccessNode.h"

is that actually used?

>-CAccessibleHyperlink::QueryInterface(REFIID iid, void** ppv)
>+ia2AccessibleHyperlink::QueryInterface(REFIID iid, void** ppv)
> {
>   *ppv = NULL;
> 
>   if (IID_IAccessibleHyperlink == iid) {
>-    nsRefPtr<Accessible> thisObj = do_QueryObject(this);
>+    Accessible* thisObj = static_cast<AccessibleWrap*>(this);
>     if (!thisObj->IsLink())
>       return E_NOINTERFACE;

it seems you don't need the local variable.

>-CAccessibleHyperlink::get_anchor(long aIndex, VARIANT *aAnchor)
>+ia2AccessibleHyperlink::get_anchor(long aIndex, VARIANT* aAnchor)

type* name


I'm pretty sure this is fine, but it would be nice if David could tkae a glance and make sure I'm not missing something.
Comment 4 Mark Capella [:capella] 2012-06-22 20:27:43 PDT
Created attachment 636020 [details] [diff] [review]
Patch (v3)

Nits addressed, and asking David to look this over as well ...
Comment 5 David Bolter [:davidb] 2012-06-25 06:26:31 PDT
Comment on attachment 636020 [details] [diff] [review]
Patch (v3)

Review of attachment 636020 [details] [diff] [review]:
-----------------------------------------------------------------

looks fine - thanks. r=me
Comment 6 Mark Capella [:capella] 2012-06-25 18:31:37 PDT
Push to TRY:
https://tbpl.mozilla.org/?tree=Try&rev=15c5068f7831
Comment 7 Mark Capella [:capella] 2012-06-26 01:39:04 PDT
On to inbound:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=49819cb04654
Comment 8 Ed Morley [:emorley] 2012-06-26 09:24:49 PDT
https://hg.mozilla.org/mozilla-central/rev/49819cb04654
Comment 9 alexander :surkov 2012-10-07 16:40:12 PDT
*** Bug 741702 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.