Closed Bug 767292 Opened 8 years ago Closed 7 years ago

Image moves slightly up/down or left/right with transform scale and opacity images

Categories

(Core :: Graphics, defect)

14 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox14 - ---
firefox15 - ---
firefox16 - ---

People

(Reporter: alice0775, Assigned: ebassi)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/10e019421e6b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120621053048

When I tested Bug 767281, I noticed the position gap of the image.

Steps to Reproduce:
1. Open attachment 635651 [details]

Actual Results:
 Image moves slightly up/down or left/right

Expected Results:
 Not move


There are 2 regression.
#1 Images ignores transform scale when opacity applied
#2 Partially Fixed #1 regression. but Images moves slightly up and down


#1 Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/e1ae143cc842
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111026 Firefox/10.0a1 ID:20111026120007
Bad:
http://hg.mozilla.org/mozilla-central/rev/16a8d2ab5240
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111026 Firefox/10.0a1 ID:20111026163203
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e1ae143cc842&tochange=16a8d2ab5240

#1 Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/98013fe19dcb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111025 Firefox/10.0a1 ID:20111025195747
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d7f3bfc7cd46
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111025 Firefox/10.0a1 ID:20111025203245
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=98013fe19dcb&tochange=d7f3bfc7cd46
Triggered by:
8b89d7037306	Matt Woodrow — Bug 695275 - Fix conversion of ThebesLayers to ImageLayers. r=roc



#2 Regression(Pertial fix) window(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/c00a9c1940c5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120515185430
Bad(Partially fix):
http://hg.mozilla.org/mozilla-central/rev/bfc259be3fa2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120516020729
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c00a9c1940c5&tochange=bfc259be3fa2

#2 Regression(Pertial fix) window(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b69d000b726a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120514231326
Bad(Partially fix):
http://hg.mozilla.org/integration/mozilla-inbound/rev/dd3c873674fc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120515030522
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b69d000b726a&tochange=dd3c873674fc
Triggered by:
dd3c873674fc	Matt Woodrow — bug 750334 - rotating image appears too big during transition, then snaps to correct size r=roc
And bug 750334 was already uplifted to 14Beta.
Not a recent regression, and doesn't have a significant user impact. Any fix here would ride the trains given that.
To Emmanuele for a look...
Assignee: nobody → ebassi
Attached file updated test case
the test case is an adaptation of the original in attachment 635651 [details] to try and pinpoint the failure cases.

it seems that the regression appears if the <img> changing opacity is on top of another <img>; if the image is on top of <div> (of any opacity), of if both images are replaced by <div>s, the regression disappears.
cannot reproduce in Nightly 19.0a1 (2012-11-06) on my Fedora 17; I think we can chalk this one up to the DisplayList invalidation code.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.