Closed Bug 767298 Opened 12 years ago Closed 12 years ago

Gmail: Deleting emails causes browser to crash

Categories

(Core :: DOM: Core & HTML, defect)

14 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 763702
Tracking Status
firefox14 --- affected
firefox15 --- affected
firefox16 --- unaffected

People

(Reporter: zcampbell, Unassigned)

Details

(Keywords: crash, reproducible, Whiteboard: [native-crash])

Crash Data

To replicate:

1. Log into Gmail on Firefox Beta (Fennec native)
2. Get some friends to send you some emails or if you have no friends just email yourself
3. From the inbox select email(s) using the checkboxes
4. Click 'delete' button at the bottom of the page.
5. Firefox Beta will crash.
Fx: Fennec/Firefox 14
Hardware: HTC Desire HD
Android: 2.3.5
Are you able to submit a crash report by going to about:crashes? If so please provide the crash report ID.
Component: Web Apps → General
QA Contact: web-apps → general
I will as soon as I work out how to fix the other issue (bug 767301)!
Try to access about:crashes in XUL Fennec 10.0.5.
Keywords: crash, stackwanted
Hardware: Other → ARM
Whiteboard: [native-crash]
I managed to extract the report by saving to PDF and then viewing the PDF.

These are the crash reports:

6/21/12
23:41 
https://crash-stats.mozilla.com/report/index/2347913e-881a-437a-b769-eaa302120621
23:37
https://crash-stats.mozilla.com/report/index/4e5cf58c-a066-4a41-9f11-2d79f2120621
23:36
https://crash-stats.mozilla.com/report/index/e42a2808-08ec-481f-a0d0-bd0402120621

(there are some other reports too but the timestamps don't match this when I triggered this bug)
(In reply to Zac C from comment #5)
> https://crash-stats.mozilla.com/report/index/4e5cf58c-a066-4a41-9f11-
> 2d79f2120621
This one is bug 765678.
Crash Signature: [@ TouchBadMemory | mozalloc_abort | moz_xmalloc | NS_NewHTMLImageElement ]
Component: General → DOM: Core & HTML
Keywords: stackwanted
Product: Fennec Native → Core
QA Contact: general → general
Version: Firefox 14 → 14 Branch
Yeah I think the first one (23:36) is this bug. The following ones are me re-starting Fennec and trying again.
I can reproduce this on Beta; nominating for blocking for evaluation.

On Nightly, I don't crash but I get an XML Parsing Error: not well-formed error

--
Firefox Beta 14.0 Beta 8, 
Samsung Galaxy Nexus (Android 4.0.4)
tracking-fennec: --- → ?
blocking-fennec1.0: --- → ?
Keywords: reproducible
Ouch. I can reproduce on Beta as well.

Samsung Galaxy S2 (Android 4.0.3)
Does it happen in Aurora?
Same here on Galaxy Nexus 4.04, latest FF 14 Beta
Confirmed; Aurora (06.22)
(In reply to Aaron Train [:aaronmt] from comment #8)
> On Nightly, I don't crash but I get an XML Parsing Error: not well-formed
> error

Confirmed on the Nightly side. Could you file a separate bug for that?
(In reply to Aaron Train [:aaronmt] from comment #12)
> Confirmed; Aurora (06.22)

Hmm. I wonder if this is a regression. Can someone get a regression range?
My gut is that we don't hold the release for this, but that we fix it in .N. Android devices will have a gmail app, so there is a ready workaround for any user impacted. Usually I'd consider gmail a marquee site, but I suspect its usage in android browsers is actually much lower.

Obviously we should still investigate here, though, and I'd like to know what other drivers think, too.
Wow! But I agree with Johnath. Let's get this in a debugger and try to get a .N+ fix.
(In reply to Mark Finkle (:mfinkle) from comment #16)
> Wow! But I agree with Johnath. Let's get this in a debugger and try to get a
> .N+ fix.

One question I'd like to know - do we know are there any other top sites affected by this crash? Naoki - What other URLs are showing crashes here?
Strange, i can reproduce a crash in comment 0 when deleting a gmail, but i get a different crash.

Environment: Galaxy Nexus, Fx 14 Beta 8, Android 4.0.4

https://crash-stats.mozilla.com/report/index/bp-4358c824-f2a1-4ff3-b0a2-b8a232120622

0 	libxul.so 	nsFontInflationData::FindFontInflationDataFor 	layout/generic/nsIFrame.h:1361
1 	libxul.so 	nsLayoutUtils::InflationMinFontSizeFor 	layout/base/nsLayoutUtils.cpp:4778
2 	libxul.so 	nsLayoutUtils::FontSizeInflationFor 	layout/base/nsLayoutUtils.cpp:4802
3 	libxul.so 	nsHTMLReflowState::CalcLineHeight 	layout/generic/nsHTMLReflowState.cpp:2321
4 	libxul.so 	nsBlockReflowState::nsBlockReflowState 	layout/generic/nsBlockReflowState.cpp:149
Isn't this by any chance basically bug 763702? I got that crash on the Galaxy Nexus, using Fennec14b while deleting mail and I get the xml parsing error on trunk.
I get that too; yes this is a dupe of bug 763702. Let's nominate that one.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
(In reply to Aaron Train [:aaronmt] from comment #20)
> ... 'Let's nominate that one.
tracking-fennec: ? → ---
blocking-fennec1.0: ? → ---
URL : about:blank is all I see.  no useful URLs.  URLs shown are only the active tab.
You need to log in before you can comment on or make changes to this bug.