Last Comment Bug 767384 - The script from the dropdown is kept when loading a page with no scripts after loading one with scripts and opening the Debugger
: The script from the dropdown is kept when loading a page with no scripts afte...
Status: VERIFIED FIXED
[testday-20120706]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 15 Branch
: All All
P2 normal (vote)
: Firefox 16
Assigned To: Victor Porof [:vporof][:vp]
:
: Jason Laster [:jlast]
Mentors:
: 770468 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 07:58 PDT by Ioana (away)
Modified: 2012-07-31 08:29 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (1.67 KB, patch)
2012-07-03 05:59 PDT, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Splinter Review
screenshot (141.18 KB, image/pjpeg)
2012-07-13 03:34 PDT, Diwakar Sharma
no flags Details
v2 (4.92 KB, patch)
2012-07-15 00:06 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review

Description User image Ioana (away) 2012-06-22 07:58:14 PDT
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20120621 Firefox/15.0a2 (20120621042006)

STR:
1. Load http://htmlpad.org/debugger/ in the browser.
2. Open the Debugger (Tools->Web developer->Debugger, or press Ctrl+Shift+S).
3. Load in the same tab a page with no JSs:
e.g.:
<!DOCTYPE html> 
<html>
  <head></head>
  <body>asasdfasd</body>
</html>

The script that was selected in the dropdown before step 3 stays loaded for the page without any scripts too.
Comment 1 User image Victor Porof [:vporof][:vp] 2012-06-22 09:46:05 PDT
Yup, I can reproduce this. Shouldn't happen. Taking.
Comment 2 User image Victor Porof [:vporof][:vp] 2012-07-03 05:51:18 PDT
Testing with 

http://htmlpad.org/debugger/
and
http://htmlpad.org/no-script/
Comment 3 User image Victor Porof [:vporof][:vp] 2012-07-03 05:59:59 PDT
Created attachment 638677 [details] [diff] [review]
v1
Comment 4 User image Panos Astithas [:past] 2012-07-04 06:35:04 PDT
*** Bug 770468 has been marked as a duplicate of this bug. ***
Comment 5 User image Panos Astithas [:past] 2012-07-04 06:44:36 PDT
Comment on attachment 638677 [details] [diff] [review]
v1

Review of attachment 638677 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with a test that makes sure we won't regress this.
Comment 6 User image Alfredos-Panagiotis Damkalis [:fredy] 2012-07-06 05:10:59 PDT
Just to add that If the no-script html page is loaded by hitting the back or the forward button then the bug shows up.
Comment 7 User image Diwakar Sharma 2012-07-13 03:33:23 PDT
still not resolved please see the screenshot attached

browserversion : Aurora 15.0a2 (2012-07-12)
OS : Windows 7 32-bit
Comment 8 User image Diwakar Sharma 2012-07-13 03:34:43 PDT
Created attachment 641799 [details]
screenshot
Comment 9 User image Panos Astithas [:past] 2012-07-13 03:40:13 PDT
(In reply to Diwakar Sharma from comment #7)
> still not resolved please see the screenshot attached

Well, the patch hasn't landed yet, we're waiting for a test.
Comment 10 User image Victor Porof [:vporof][:vp] 2012-07-13 07:42:39 PDT
Getting back to this right now.
Comment 11 User image Victor Porof [:vporof][:vp] 2012-07-15 00:06:45 PDT
Created attachment 642342 [details] [diff] [review]
v2

Added test.
Comment 12 User image Panos Astithas [:past] 2012-07-15 06:46:22 PDT
https://hg.mozilla.org/integration/fx-team/rev/21d5e58533e0
Comment 13 User image Ed Morley [:emorley] 2012-07-16 05:26:22 PDT
https://hg.mozilla.org/mozilla-central/rev/21d5e58533e0
Comment 14 User image Alfredos-Panagiotis Damkalis [:fredy] 2012-07-24 02:25:29 PDT
I checked at latest Aurora (Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/16.0 Firefox/16.0) and Nightly and the bug is resolved.

However there is a difference between Aurora and Nightly. At Nightly when the no-script page is loaded then the dropdown menu has the tag "No scripts". At Aurora the dropdown menu hasn't any tag, it is just blank.

Can somebody confirm this behavior at Aurora? Is this behavior intended?
Comment 15 User image Panos Astithas [:past] 2012-07-31 06:33:48 PDT
(In reply to Alfredos-Panagiotis Damkalis from comment #14)
> I checked at latest Aurora (Mozilla/5.0 (X11; Linux x86_64; rv:16.0)
> Gecko/16.0 Firefox/16.0) and Nightly and the bug is resolved.
> 
> However there is a difference between Aurora and Nightly. At Nightly when
> the no-script page is loaded then the dropdown menu has the tag "No
> scripts". At Aurora the dropdown menu hasn't any tag, it is just blank.
> 
> Can somebody confirm this behavior at Aurora? Is this behavior intended?

I think this is the fix from bug 771481 that isn't in Aurora.
Comment 16 User image Alfredos-Panagiotis Damkalis [:fredy] 2012-07-31 08:29:27 PDT
You are right, so I change this one to verified. Thanks for the fix :)

Note You need to log in before you can comment on or make changes to this bug.