Arrows to scroll down for results on ringmark's website are broken

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Loic, Unassigned)

Tracking

({regression})

15 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
STR

1) Open http://rng.io/ and wait until the test is finished.
2) Click on the arrows to scroll down for results.

Result:
Arrows are broken and don't open a menu with results.

Mozregression range:

m-c
2012-05-08
2012-05-09
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1092c1a3ac50&tochange=dd29535bac5f

m-i
2012-05-07
2012-05-08
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=86f237e55dd9&tochange=f18d4a2fce0d

Reported here: http://forums.mozillazine.org/viewtopic.php?p=12086555#p12086555
(Reporter)

Updated

6 years ago
Keywords: regression
(Reporter)

Updated

6 years ago
(Reporter)

Updated

6 years ago
Duplicate of this bug: 767565

Comment 2

6 years ago
Warning: ReferenceError: reference to undefined property f.event.triggered
Source file: http://rng.io/dist/application.min.js
Line: 3

Warning: ReferenceError: reference to undefined property a.returnValue
Source file: http://rng.io/dist/application.min.js
Line: 3

Warning: ReferenceError: reference to undefined property c.result
Source file: http://rng.io/dist/application.min.js
Line: 3

Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/cab8af0ca040
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120507121828
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7b11e6c758c8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120507124827
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cab8af0ca040&tochange=7b11e6c758c8

Last Good: 2998b1105a11
First Bad: 78c508bfee65

Triggered by Bug 249159

Comment 3

6 years ago
It works if one of test ring0 got failure.

STR
1. Open http://rng.io/
2. Zoom-out * 6 or zoom-in * 7 (browser memorize zoom level for rng.io )
3. Close the tab
4. Clear Resent History except "Site Preferences"
5. Open http://rng.io/

I guess this is the Site problem.
Has someone reported this to the site?

Comment 5

6 years ago
I was the one who reported it at mozillazine forums, and at least I didn't report it to the original site (would not be able to tell them more than "click doesn't work").
OK.  I'll see what I can do to get in touch with these people.
(Reporter)

Comment 7

6 years ago
I saw the issue has been reported on GitHub:
https://github.com/facebook/rng.io/issues/21

But the bug ticket has been closed because of FF16 is still in alpha/beta channel.

Comment 8

6 years ago
In the current nightly on desktop (Windows), seems to work fine, but in nightly mobile its not working.

Comment 9

6 years ago
(In reply to JP Rosevear [:jpr] from comment #8)
> In the current nightly on desktop (Windows), seems to work fine

I lied, or at least, its not consistently working here.

Comment 10

6 years ago
The upstream bug implies that fixing 591737 would help.
(Reporter)

Comment 11

6 years ago
It looks like Ringmark has updated its website, because arrows to display the results work now with Nightly.
But now Firefox 17 (and 14) fails to pass ring 0 (geolocation methods)...
http://i.imgur.com/t9yED.jpg
That was a bug in the newly rewritten geolocation tests. The bug has been resolved and no longer exists.
> because arrows to display the results work now with Nightly.

This was only happening because of the ring 0 test failure.  See comment 3.

Comment 14

6 years ago
Sat down with Jet and it looks like this is still an issue, I'll take a look post-vacation.
@Matt

What version are you looking in?
Matt, I debugged this in mozilla bug 783301 and filed an issue with rng.io. I put up a bad fix there, then figured out a better one but haven't had time to work on it again. I don't have a lot of time to work on it or the desire to sign a license agreement with Facebook just to put up a fix, so if you wan to take it, please do:

https://github.com/facebook/rng.io/pull/34
The problem is related to a bad polyfill for the html5 summary and details element in Firefox. Marking dependency, but the polyfill should be fixed as well.
Depends on: 591737
Duplicate of this bug: 783301

Comment 19

5 years ago
This is now fixed on their side. Supporting <details> and <summary> properly will fix the underlying bug. 

Please close.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.