Disabling Junk Filters change does not take

RESOLVED DUPLICATE of bug 536768

Status

RESOLVED DUPLICATE of bug 536768
6 years ago
6 years ago

People

(Reporter: zane, Unassigned)

Tracking

13 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5

Steps to reproduce:

I have been having an issue where mail ( I assume interpreted as junk mail ) does not go to the junk mail folder.  I have no filters enabled that delete.

That issue asside,  when I try to debug I go to the account settings and disable the junk filter.  Every time I return to the account settings the enable junk filter check mark returns.


Actual results:

I can not disable junk message filtering.  I uncheck the enable option in account settings.  Click apply.  Return to settings and it is checked again.  I actually have 2 accounts and the local account.  This issue applies to all 3.  In fact if I view the junk message settings in one account,  uncheck,  click on any other setting and click back on the junk message setting I just changed, it is checked again.


Expected results:

The enabled junk mail setting should remain unchecked and junk mail should not be filtered.

Comment 1

6 years ago
Do you use the Global inbox (the problematic POP3 account is set to store its incomming messages into another account)? Can you attach a screenshot of your Junk settings pane when you come back and the junk filter is enabled by itself?
(Reporter)

Comment 2

6 years ago
(In reply to :aceman from comment #1)
> Do you use the Global inbox (the problematic POP3 account is set to store
> its incomming messages into another account)? Can you attach a screenshot of
> your Junk settings pane when you come back and the junk filter is enabled by
> itself?

I use the Global inbox.  I have two POP3 accounts,  both set to use Global Inbox (Local Folders Account).  All of the 3 accounts (2 POP3 and one local) look the exact same.

http://i.minus.com/ibjMxv3TViCsNp.png

Even if I set the option "To Junk Folder On:" to Local it blanks out as well when I move from one setting to another.  This has been my observation with these settings for a couple years now on multiple computers.  You should be able to replicate.

I appreciate any support.
(Reporter)

Comment 3

6 years ago
FYI,  I have reset all of my settings and disabled all plugins using the safemode option.

Comment 4

6 years ago
From the screenshot (the empty folder pickers) this is bug 536768. It is an old known problem, but hopefully it is nearing a solution (there is a patch from me:)).

You need to temporarily disable the global inbox (make each POP3 account store mail into itself), then go into Junk settings of each POP3 account, set the junk target folders to be Local Folders and Local Folders/Junk and then disable Junk mail controls. Close the account settings and go back to see if the settings now stick. If yes, you can enable global inbox on both POP3 accounts again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 536768
(Reporter)

Comment 5

6 years ago
That did the trick!

Sorry, I did not find bug 536768 in my search!  Thanks for your time.
You need to log in before you can comment on or make changes to this bug.