pdf.js: Many pdf documents "might not be displayed correctly"

RESOLVED WORKSFORME

Status

()

Firefox
PDF Viewer
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Jonathan Haas, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-gradient-extend])

(Reporter)

Description

6 years ago
Recently, when opening a pdf document, I often get a yellow message bar that the displayed "pdf document might not be displayed correctly". Usually the pdf document is then displayed correctly in this case.

This even happens for extremely simple pdf documents like attachment 609044 [details] from bug 738979.

I'm not entirely sure about the cause of this, but it is clearly not a situation the pdf viewer should be shipped with, because it may confuse users and is annoying.
Currently we try to trigger the bar on any thing we think may cause the PDF to displayed incorrectly.  As we get a better feel for what might actually cause problems(and add more support) we'll be backing this off and the bar should show up much less.
The web console contains the following text:

> [16:51:09.485] Warning: TODO: Support extend

The "pdf document might not be displayed correctly" is valid in this case. The issue is recorded at https://github.com/mozilla/pdf.js/issues/257
Version: 15 Branch → Trunk

Updated

6 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-d-gradient-extend]

Comment 3

6 years ago
Not sure whether this is an issue or working as intended, but either way, it definitely happens a lot.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

5 years ago
FWIW: Firefox version 19.0 - Jan 14, 2013 happens regularly here since version 18.0

Comment 5

5 years ago
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

The following two documents also have this issue, even though the documents appear to render correctly in the PDF viewer, based on a visual inspection of the same document rendered in Adobe Reader. The trigger for the 'this PDF document might not be displayed correctly' message seems to be caused by a warning in PDF.js:618.

http://www.cs.princeton.edu/theory/complexity/spacechap.pdf
Warning: Switching TrueType encoding to MacRomanEncoding for LRQIYZ+Arial font

http://www.ambri.com/storage/documents/careers/AMBRI_Cell_Analysis_Co-op.pdf
Warning: Switching TrueType encoding to MacRomanEncoding for ABCDEE+Verdana font

This happens on other PDF documents, and is a bit disconcerting when the document displays correctly but warns that it may not display correctly. I am sure there are valid warnings that should trigger the message, but I'm not convinced that this is one of them.

Since Adobe does not warn about this particular issue, it would also be nice if pdf.js did not warn about the issue either.
Works for me with the latest Nightly.
We should close this or make this bug a tracking bug to track individual technical problems.

Comment 7

5 years ago
This is just like the annoying and persistent "this page is missing a plugin" pop-up every time I visit a page with Flash on it (I disabled this in about:config - an unacceptable solution).  I don't have Flash installed on my mac as a security precaution.  Since Chrome has Flash built in, I use it pretty much solely for viewing flash sites.

The issue here is not whether there is really a problem or an error.  This is a usability issue.  We need to stop thinking like robot developers and realize that sometimes we have to change the way we do things to make better software.

The options to remove both of these warnings would not be bloat.  Let's not move toward Apple's "We know how you want to use our product better than you, so stop complaining" model.  This is Mozilla!!  ;)

BTW, I'm using FF 20.0
(Reporter)

Comment 8

5 years ago
The sample attachment now doesn't display a warning, but lots of pdf files still do and this is still very annoying. I estimate that around 40% of all pdf files I have viewed in the last weeks "might not have been displayed correctly".

This is just bad usability as either you choose to ignore the warning but you may miss important details (compare for example Bug 741239 or Bug 760997) or you are forced to open the document in an external viewer which renders the internal viewer in Firefox pretty much useless and adds extra steps and time to view documents.

Comment 9

5 years ago
I close this bug because all the PDF provided in the comments work fine now with FF25 and it's not about a specific issue in the PDF Viewer (like a missing feature or a parsing bug).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.