Closed Bug 741239 Opened 11 years ago Closed 9 years ago

pdf.js: annotations are not displayed

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 24
Tracking Status
firefox20 - ---

People

(Reporter: jonathan_haas, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-annotations][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3305)

Attachments

(3 files)

Attached file Testcase
The attached pdf file is not correctly displayed by Firefox. It was edited in some editor, which added annotations like the green "OK" icons you see in proper pdf viewers like adobe or foxit reader. In Firefox you just see the plain scanned paged without annotations.
Blocks: 714712
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86_64 → All
Still a problem, a big one. Should be fixed. Tracking on Github:

https://github.com/mozilla/pdf.js/issues/1973
Severity: normal → critical
Whiteboard: [pdfjs-c-feature]
OS: Windows 7 → All
This is still an issue but in Firefox 19.0b5 I get a notification bar indicating that it might not be displayed correctly, offering to open it in a different viewer. Clicking the "Open in Different Viewer" button downloads the file and opens in my system's PDF viewer correctly.

In terms of shipping PDF.js in Firefox 19, I think this is sufficient. I think we should try to get this fixed for Firefox 20 if at all possible though.
No need to track for release, but we would accept a low risk uplift.
Duplicate of this bug: 849527
This is a dangerous bug, for reasons listed in Bug 849527.  
 
Noting to the community, here, that commentary in various related bugs indicates that this is still present in nightlies (to v22?).

Also, may I suggest addressing, with this bug, the resolution of the error bar and install issues noted in Bug 849527.
See also: Bug 848476, Bug 849527, Bug 845650 and Bug 849357
For overlapping bugs issues, and for variable importance ratings...
Whiteboard: [pdfjs-c-feature] → [pdfjs-c-rendering][pdfjs-d-annotations][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3305
Seems to be partially fixed in current aurora (2013-06-11), the red and green markings are now visible but some text is still missing. Also Firefox doesn't display a yellow bar ("night not be displayed correctly") anymore but it should obviously.
Duplicate of this bug: 890259
Yes, there is a weird regression.
Aurora is able to display annotations (or partially, maybe) but Nightly fails again.

See bug 890259 for simple PDF with annotations or:
http://www.broadband-xp.com/test/pdfjs/annotation-tx2.pdf
http://www.broadband-xp.com/test/pdfjs/annotation-tx3.pdf
Flags: needinfo?(ydelendik)
Forget previous comment, sorry.
Flags: needinfo?(ydelendik)
Test Case :

Open PDF   --> Acrobat reader .
Annotation --> Highlighting the important Words / Sentences .
           --> Color will be changed (yellow) .
           --> Save the file and closed .
           --> open the PDF file using Firefox .
           --> But highlight is not getting rendering in the PDF .

Attachment --> highlighted PDF
It's already fixed in Nightly.
(In reply to Loic from comment #13)
> It's already fixed in Nightly.

Raghuraman, can you please download the latest Firefox Nightly from nightly.mozilla.org and confirm?
sure
 
i am using  ff22 now  is there any new procedure for downloading the Nightly build or 

same  as usual 

Help --> About FF --> Check for updates .

?
Sorry Anthony i got it once i tested it i will update the test result .
ya i tested and working fine as expected 

Scenario 1 --> Highlighted Text (Checked word and each character starting point to end point eg  "word" , "wor"d )

Scenario 2 --> scenario 1 + Notes 

Both are working fine .
Please also check the "Testcase" pdf attachment, we know some annotations are already fixed, but some annotation text was still missing from this testcase last time I checked.
Also, I checked it myself in latest Aurora and it seems to work fine.

Can probably be marked as fixed (I'm not allowed to do so).
It's partially fixed. The annotation is highlighted but chars are truncated.
Depends on: 878897
1.  See other bugs for possible additional uploaded test cases.  Comments 4 and 6 list some bugs.  There might be yet others out there...?

2.  I wonder: have the defects/bugs in AdobePDF, which propelled this PDF project, been cured since the project began?   Or is there an underlying failure/method which leaves AdobePDF or other readers (eg, NitroPDF) inherently dangerous ?
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
You need to log in before you can comment on or make changes to this bug.