Cache windows handle used for stackwalking

RESOLVED FIXED in mozilla16

Status

()

Core
Gecko Profiler
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: BenWa, Assigned: Ehsan)

Tracking

unspecified
mozilla16
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Currently we duplicate the handles every time we walk the stack:
http://mxr.mozilla.org/mozilla-central/source/xpcom/base/nsStackWalk.cpp#459

We should cache these when start the profiler instead of duplicating them each time.
Created attachment 635929 [details] [diff] [review]
Part 1: Cache the current process handle after reading it for the first time during stack walking
Attachment #635929 - Flags: review?(dbaron)
Comment on attachment 635929 [details] [diff] [review]
Part 1: Cache the current process handle after reading it for the first time during stack walking

r=dbaron
Attachment #635929 - Flags: review?(dbaron) → review+
Blocks: 713278
No longer blocks: 713278
https://hg.mozilla.org/integration/mozilla-inbound/rev/2cbf12886c89
Target Milestone: --- → mozilla16
https://hg.mozilla.org/mozilla-central/rev/2cbf12886c89
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 763723
You need to log in before you can comment on or make changes to this bug.