Exclude desktop/tablet apps on mobile

RESOLVED FIXED in 2012-09-27

Status

Marketplace
Consumer Pages
P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: cvan, Assigned: cvan)

Tracking

2012-09-27
Points:
---

Details

(URL)

(Assignee)

Description

6 years ago
There might be an desktop-only or tablet-only apps: http://cl.ly/243n2k183s3v010f0625

So this begs the question:
- Should we exclude those apps when viewing the Marketplace on your mobile device?
- If we exclude non-mobile apps, should the compatibility be listed on the detail page (as it currently is - http://cl.ly/0X213G0N3W0Z0m3A2d0o)?
- If we include mobile apps, what does it look like to toggle between compatible vs. incompatible search results/browse pages?
(Assignee)

Updated

6 years ago
Keywords: uiwanted
I didn't think we were doing this for the first version of the marketplace because I don't know how it would work technically.  If your screen is resized to be smaller search results suddenly disappear or...?

Updated

6 years ago
blocking-basecamp: --- → ?
(Assignee)

Comment 2

6 years ago
(In reply to Wil Clouser [:clouserw] from comment #1)
> I didn't think we were doing this for the first version of the marketplace
> because I don't know how it would work technically.  If your screen is
> resized to be smaller search results suddenly disappear or...?

It's totally doable. Yeah it could totally get confusing like it has been with Mobile AMO where you see something in search results on desktop but not on mobile.

If I recall correctly, this was something that product and UX wanted.
(Assignee)

Comment 3

6 years ago
Justin, can you confirm this? ^
(In reply to Chris Van Wiemeersch [:cvan] from comment #3)
> Justin, can you confirm this? ^

From a UX perspective I don't think it makes sense to show incompatible apps on mobile. Can't we do something more clever than need to change the results based on browser window size? The use case of actually being on a mobile device is different than the use case of resizing your desktop browser window to "mobile size" - hence the "there is more to responsive design than just screensize" type talk.
(Assignee)

Comment 5

6 years ago
(In reply to Maria Sandberg [:mushi] from comment #4)
> (In reply to Chris Van Wiemeersch [:cvan] from comment #3)
> > Justin, can you confirm this? ^
> 
> From a UX perspective I don't think it makes sense to show incompatible apps
> on mobile. Can't we do something more clever than need to change the results
> based on browser window size? The use case of actually being on a mobile
> device is different than the use case of resizing your desktop browser
> window to "mobile size" - hence the "there is more to responsive design than
> just screensize" type talk.

The detection is easy. We have a non-screen-size way of checking whether we're in B2G. So that's not a problem.

But the consequences of filtering content by medium - are those something to worry about?
Priority: -- → P3
(Assignee)

Comment 6

6 years ago
In chatting with Maria, Davor, Potch, and Justin yesterday I think we concluded that users should be able to view a detail page of a non-mobile app on mobile, but the apps should be excluded from home/search/browse/etc.
Keywords: uiwanted
Summary: Do we exclude desktop/tablet apps on mobile? → Exclude desktop/tablet apps on mobile
Thanks.  We should do this for basecamp as the UX will be way better.
Assignee: msandberg → nobody
blocking-basecamp: ? → +
Priority: P3 → P1
Target Milestone: --- → 2012-08-02
Assignee: nobody → cvan
Important point worth noting (although probably not directly related to the implementation of this bug, but the implications) - take into account that not all mobile apps that say they are mobile happen to be mobile. Also note that we are landing a change to change the user agent in Firefox OS to drop the platform, so this might affect the factor of what apps actually are mobile vs. what apps are listed as mobile. I'll open a bug in the reviewer tools for an idea that might address this.
(Assignee)

Comment 9

6 years ago
This is pretty essential now.
Target Milestone: 2012-08-02 → 2012-08-09
(Assignee)

Comment 10

6 years ago
So let's start doing a fragment load on the initial synchronous page load. When we do fetch fragment ask for `?medium=mobile`. Ask potch or cvan for help.
Assignee: cvan → ngoke

Updated

6 years ago
Priority: P1 → P2
Priority: P2 → P1
(Assignee)

Updated

6 years ago
Assignee: ngoke → mattbasta
Target Milestone: 2012-08-09 → 2012-08-16

Comment 11

6 years ago
I'll have this done soon but as a heads up, I'm not going to add code to filter featured apps on the homepage. Should I add this in?
Yes, all public app listings should only include compatible apps. The exceptions are Account History/My Apps, and user profile pages which we don't care about right now.

Search will be tricky as we need to work with filters and name-based queries -- check how we do it on AMO.

Comment 13

6 years ago
Oh man this is fantastic. Merged:

https://github.com/mozilla/zamboni/commit/c20801f2170a2942f06e4c7754a411fee17814d5
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
w00t

Comment 15

6 years ago
This is not working. On doing a blank search, i see no results at all (there are 173 mobile apps)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 16

6 years ago
Should be fixed now
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

6 years ago
I'm not sure if the gaia merge broke your stuff, but I figured you should know your tests fail now :(

======================================================================
FAIL: test_generator (zamboni3.mkt.search.tests.test_views.TestFilterMobileCompat)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/chris/Sites/projects/zamboni3/../zamboni3/mkt/search/tests/test_views.py", line 519, in test_generator
    func(*params)
  File "/Users/chris/Sites/projects/zamboni3/../zamboni3/mkt/search/tests/test_views.py", line 492, in test_url
    "Couldn't find mobile app for %s" % url)
AssertionError: Couldn't find mobile app for /?mobile=false

======================================================================
FAIL: test_mobile_applied_filters (zamboni3.mkt.search.tests.test_views.TestFilterMobileCompat)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/chris/Sites/projects/zamboni3/../zamboni3/mkt/search/tests/test_views.py", line 535, in test_mobile_applied_filters
    assert p_desktop('#device-facets')
AssertionError: 
-------------------- >> begin captured logging << --------------------
elasticutils: DEBUG: [1] {'sort': [{'popularity': 'desc'}], 'query': {'bool': {'must': [{'term': {'status': 4}}, {'term': {'is_disabled': False}}, {'term': {'type': 11}}]}}, 'facets': {'category': {'terms': {'field': 'category'}}}, 'size': 0, 'fields': ['id']}
elasticutils: DEBUG: [1] {'sort': [{'popularity': 'desc'}], 'query': {'bool': {'must': [{'term': {'status': 4}}, {'term': {'is_disabled': False}}, {'term': {'type': 11}}]}}, 'facets': {'category': {'terms': {'field': 'category'}}}, 'size': 2, 'fields': ['id']}
elasticutils: DEBUG: [1] {'sort': [{'popularity': 'desc'}], 'fields': ['id'], 'facets': {'category': {'terms': {'field': 'category'}}}, 'filter': {'and': [{'term': {'uses_flash': False}}, {'term': {'device': 2}}]}, 'query': {'bool': {'must': [{'term': {'status': 4}}, {'term': {'is_disabled': False}}, {'term': {'type': 11}}]}}, 'size': 0}
elasticutils: DEBUG: [1] {'sort': [{'popularity': 'desc'}], 'fields': ['id'], 'facets': {'category': {'terms': {'field': 'category'}}}, 'filter': {'and': [{'term': {'uses_flash': False}}, {'term': {'device': 2}}]}, 'query': {'bool': {'must': [{'term': {'status': 4}}, {'term': {'is_disabled': False}}, {'term': {'type': 11}}]}}, 'size': 1}
elasticutils: DEBUG: [1] {'sort': [{'popularity': 'desc'}], 'fields': ['id'], 'facets': {'category': {'terms': {'field': 'category'}}}, 'filter': {'and': [{'term': {'uses_flash': False}}, {'term': {'device': 2}}]}, 'query': {'bool': {'must': [{'term': {'status': 4}}, {'term': {'is_disabled': False}}, {'term': {'type': 11}}]}}, 'size': 1}
--------------------- >> end captured logging << ---------------------

----------------------------------------------------------------------
Ran 45 tests in 46.586s

Comment 18

6 years ago
Do we no longer have a "popular" or "latest" section on the homepage? If so, that line in the test can be removed because we only care about listings and not about featured apps.
(Assignee)

Comment 19

6 years ago
(In reply to Matt Basta [:basta] from comment #18)
> Do we no longer have a "popular" or "latest" section on the homepage? If so,
> that line in the test can be removed because we only care about listings and
> not about featured apps.

We no longer have popular nor latest on homepage (only featured).

And we don't have search filters on search anymore :\

Comment 20

6 years ago
> And we don't have search filters on search anymore :\

What does this mean?
(Assignee)

Comment 21

6 years ago
(In reply to Matt Basta [:basta] from comment #20)
> > And we don't have search filters on search anymore :\
> 
> What does this mean?

This is what the search filters look like now: http://cl.ly/image/0H181Q3o2X03

So the HTML and styles have changed completely.

Comment 22

6 years ago
Ah, ok. I don't think that affects this bug. The only thing involving search filters was the code to hide the controls to filter by device, but if those controls don't exist anymore then we don't need logic to hide them. :)
Something is affecting this bug...reopening.

From Fennec, I can search for and install (for example) Evernote Web and Starship, both of which are submitted as desktop only.  We've already got some grumbles from partners about this because their desktop apps are getting bad reviews from mobile users.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 24

6 years ago
(In reply to Lisa Brewster [:adora] from comment #23)
> Something is affecting this bug...reopening.
> 
> From Fennec, I can search for and install (for example) Evernote Web and
> Starship, both of which are submitted as desktop only.  We've already got
> some grumbles from partners about this because their desktop apps are
> getting bad reviews from mobile users.

We properly exclude the desktop-only results from *search results* but not from the inline *search suggestions*: http://f.cl.ly/items/0f2q0t2U2l0j303v2g0Z/Screen%20shot%202012-09-24%20at%204.45.43%20PM.png

Over to Basta for fix. Thanks for informing us, Lisa!
Target Milestone: 2012-08-16 → 2012-09-27
Hello folks

This is causing some serious heartburn with our partners. Evernote especially. We are trying to get them to provide the default notes app for the FFOS device and they keep asking about this.

Can we get a fixed rolled out today?

Updated

6 years ago
Assignee: mattbasta → cvan

Comment 26

6 years ago
I currently can't reproduce this on -dev since there are no search suggestions.
Steps to reproduce

1.) Access Marketplace from a mobile device.
2.) Search 'Evernote' for the 'Evernote Web' app.

NOTE: Just tried on an Otoro device and was able to install it. App is flagged as desktop only.

Thanks for looking into this.
(Assignee)

Comment 28

6 years ago
https://github.com/mozilla/zamboni/commit/691db7f
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
When will this fix be in production?
(Assignee)

Comment 30

6 years ago
(In reply to thomas elin from comment #29)
> When will this fix be in production?

Today at 2:00 PDT. Sorry for the regression, and I'll ping you when it's live!
(Assignee)

Comment 31

6 years ago
(In reply to thomas elin from comment #29)
> When will this fix be in production?

We lost power immediately after our push. But this did in fact go live yesterday (9/27) at 2:00 PDT!
I just checked on my Otoro and Evernote is NOT showing up in the search suggestions.
(Assignee)

Comment 34

6 years ago
(In reply to thomas elin from comment #33)
> I just checked on my Otoro and Evernote is NOT showing up in the search
> suggestions.

Same here.
(Assignee)

Comment 35

6 years ago
(In reply to Lisa Brewster [:adora] from comment #32)
> I'm still seeing Evernote, though: 
> http://adora.io/screens/Notification_Center-20120928-115559.jpg

Adora with your specific user-agent (Android/Gaia has since changed its user-agent), I was able to reproduce. I've landed the fix on -dev and it will be live on Thursday at 2:00 PDT. Sorry for not believing you and not fixing it promptly!

https://github.com/mozilla/zamboni/commit/66e6917
Not on-device - removing nom.
blocking-basecamp: + → ---
You need to log in before you can comment on or make changes to this bug.