Closed Bug 767695 Opened 9 years ago Closed 3 years ago

Column settings for "Open Message in Conversation" does not persist

Categories

(Thunderbird :: Folder and Message Lists, defect)

13 Branch
x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 528044

People

(Reporter: f.g.superman, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

1. In threadpane, select a message and choose "Open Message in Conversation." It then opens in a new tab.
2. In that tab, use the pulldown to change the default columns that are shown. E.g., add "Recipient" and "Size" to the columns now displayed.
3. Go back to the threadpane and repeat step 1 with a different message.


Actual results:

In the new tab, the column settings just changed do not persist. The default columns are used instead.


Expected results:

The column settings should persist. Or, there should be an option somewhere to make the current view the default. 

Btw, the same thing applies to gloda searches when the user selects "Open as list" and changes the column settings.
(In reply to wintogreen from comment #0)
See bug 750251.
Not the same, as far as I can see. That bug is about threadpane column settings not persisting after a restart of Thunderbird; this one is about column settings in the "Conversation" view (which opens as a tab separate from the main threadpane) not persisting at all, period.
(In reply to wintogreen from comment #2)
Agreed. If you apply column settings they won't be saved, if done to the conversation view. This is also the case on virtual folders in bug 660211.

Your bug report is closer to bug 574985. Because every new conversation tab/window you open should inherit the default column settings.
I agree with topicstarter.  I have similar problem.  9 times out of 10, when I use "show in conversation", I have to go into columns list and enable Location column.  It would be very nice if I could just enable it in Conversation view by default.
Component: Folder and Message Lists → Toolbars and Tabs
location column was fixed in bug 570787.
My testing shows other columns also persist.
I did not test Thunderbird restart
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Component: Toolbars and Tabs → Folder and Message Lists
Resolution: --- → WORKSFORME
Summary: View for "Open Message in Conversation" does not persist → Column settings for "Open Message in Conversation" does not persist
See Also: → 570787
The bug with the patch is bug 528044, which this bug is a dupe of, as far as I can tell. Marking as such, just in case anyone needs to track this...
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 528044
You need to log in before you can comment on or make changes to this bug.