Last Comment Bug 768367 - B2G RIL: send/received SMS failed on Otoro
: B2G RIL: send/received SMS failed on Otoro
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: ARM Linux
: -- normal (vote)
: mozilla16
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 01:49 PDT by Yoshi Huang[:allstars.chh]
Modified: 2012-06-27 03:34 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to check if rilContext.icc is defined (1.53 KB, patch)
2012-06-26 02:01 PDT, Yoshi Huang[:allstars.chh]
philipp: review+
Details | Diff | Splinter Review

Description Yoshi Huang[:allstars.chh] 2012-06-26 01:49:11 PDT
E/GeckoConsole( 115): [JavaScript Error: "this.mRIL.rilContext.icc is
null" {file:"jar:file:///system/b2g/omni.ja!/components/SmsDatabaseService.js" line:
361}]

The problem should be related to Bug 766862,
but we should make the code more defensively to prevent Sms failed due to SIM problem
Comment 1 Yoshi Huang[:allstars.chh] 2012-06-26 02:01:42 PDT
Created attachment 636631 [details] [diff] [review]
Patch to check if rilContext.icc is defined

This patch is from vivien in https://bugzilla.mozilla.org/attachment.cgi?id=636062&action=edit
Comment 2 Vicamo Yang [:vicamo][:vyang] 2012-06-26 06:06:24 PDT
Also verified in Makuro.
Comment 3 Vicamo Yang [:vicamo][:vyang] 2012-06-26 06:16:22 PDT
Sorry, it's a Akami.
Comment 4 Yoshi Huang[:allstars.chh] 2012-06-26 07:08:08 PDT
Akami also has this problem because of Bug 768428
so we also need this patch on akami
Comment 5 Philipp von Weitershausen [:philikon] 2012-06-26 09:55:47 PDT
Comment on attachment 636631 [details] [diff] [review]
Patch to check if rilContext.icc is defined

Looks ok to me. Let's see if we can fix bug 766862 somehow.
Comment 6 Yoshi Huang[:allstars.chh] 2012-06-26 14:58:46 PDT
try server:
https://tbpl.mozilla.org/?tree=Try&rev=609ec6fcafff
Comment 7 Yoshi Huang[:allstars.chh] 2012-06-26 15:10:36 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/f6a23947fc33
Comment 8 Ed Morley [:emorley] 2012-06-27 03:34:59 PDT
https://hg.mozilla.org/mozilla-central/rev/f6a23947fc33

Note You need to log in before you can comment on or make changes to this bug.