Closed Bug 768780 Opened 12 years ago Closed 12 years ago

Unexpected message window: Bad key or directory name: "/desktop/gnome/url-handlers/UTC+01/command": `+' is an invalid character in key/directory names

Categories

(Thunderbird :: General, defect)

13 Branch
x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 541130

People

(Reporter: hawran.diskuse, Unassigned)

Details

Attachments

(1 file)

7.53 KB, application/octet-stream
Details
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120615040410

Steps to reproduce:

Kicked off Thunderbird.
Forwarded one message.


Actual results:

An unexpected message box:

Bad key or directory name: "/desktop/gnome/url-handlers/UTC+01/command": `+' is an invalid character in key/directory names

appeared.
However, a message has been sent.


Expected results:

No message boxes with those ridiculous texts.

PS:
Name: Thunderbird
Version: 13.0.1
User Agent: Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20120615 Thunderbird/13.0.1
Profile Directory: Open Directory

Extensions
  British English Dictionary, 1.19.1, true, en-GB@dictionaries.addons.mozilla.org
  České slovníky pro kontrolu pravopisu, 1.0.2, true, cs@dictionaries.addons.mozilla.org
  Lightning, 1.5, true, {e2fda1a4-762b-4020-b5ad-a41df1933103}
  LookOut, 1.2.13, true, lookout@aron.rubin
  Noia 2.0 eXtreme XT, 3.38, true, noia2_full_xt@gd.noia
  Silvermel and Charamel XT, 1.5.3, true, silvermelxt@pardal.de
I've forgotten to cite the "main" message:

An error occurred while loading or saving configuration information for thunderbird-bin. Some of your configuration settings may not work properly.
(In reply to hawran from comment #1)
> I've forgotten to cite the "main" message:
> 
> An error occurred while loading or saving configuration information for
> thunderbird-bin. Some of your configuration settings may not work properly.

Does this error/warning appear for every message you forward or only this one? if only this one, can you please attach it (after removing private info) so we can check?
Well, I've just tried to forward the message again and got the same error message.
Then I've forwarded other message - without an error message.

I've noticed that the first message is one with a couple of "reply to reply" entries, the initial message has been with an "Event Invitation" (a calendar task) data.

Could you advise, please how attach it? There are a couple of furhers (=private) addresses.
Should I try to save the "Message Source" (via CTRL+U) and try to remove private info?
(In reply to hawran from comment #3)
> Should I try to save the "Message Source" (via CTRL+U) and try to remove
> private info?

Yes, save the source as .eml and before that you can remove private info.
First export as eml, then remove private data in the file and then attach here. If there is calendar data, you could try disabling Lightning addon temporarily, restart and send the message again.
(In reply to :aceman from comment #5)
> First export as eml, then remove private data in the file and then attach
> here.
Attached.
Please, If you feel I've forgotten to remove some private parts, delete my attachment.


> If there is calendar data, you could try disabling Lightning addon
> temporarily, restart and send the message again.
I've started Thunderbird in safe-mode, got the same message when forwarding the message.
Attached file A culprit
Attachment #637801 - Attachment description: Aa culprit → A culprit
I do not see any problem with this message, trying with TB16 Win XP. The invitation may have been some special data once, but now it is a normal HTML table as part of the message text. So Lightning should not be the problem.
There is no link in the message and no UTC+01 text or zone mentioned. There is a +0200 timezone. I am not sure if those zones are the same even though I am in +0200 too :)
Isn't this a duplicate of bug #541130?
(In reply to Dimitri Papadopoulos from comment #9)
> Isn't this a duplicate of bug #541130?

it is thanks for finding it
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.