Closed Bug 768873 Opened 8 years ago Closed 8 years ago

crash in F1923668373_______________________________________

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect)

x86
Windows NT
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [flash-11.3] not protected mode, WinXP only)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-2313042c-9104-4b14-856f-e382f2120627 .
============================================================= 

Seen while looking at crash stats. According to signature summary this crash affects Win XP only. It is correlated to the following Flash Versions:

Flash Version 	Percentage 	Number Of Crashes
11.3.300.262 	59.251 % 	2405
11.3.300.257 	40.158 % 	1630
11.3.300.231 	0.493 % 	20
11.3.300.214 	0.074 % 	3
11.2.202.235 	0.025 % 	1 

https://crash-stats.mozilla.com/report/list?signature=F1923668373_______________________________________


Frame 	Module 	Signature 	Source
0 	NPSWF32_11_3_300_262.dll 	F1923668373_______________________________________ 	F880709473_____________________________________________________________:421
1 	NPSWF32_11_3_300_262.dll 	F817921467______________________________________ 	F880709473_____________________________________________________________:247
2 	NPSWF32_11_3_300_262.dll 	F_2014161127__________________ 	F_768285137___________________________________________________________:164
3 	NPSWF32_11_3_300_262.dll 	F_1427895109___________________________ 	F_768285137___________________________________________________________:169
4 	NPSWF32_11_3_300_262.dll 	F96146851____________________________ 	F_768285137___________________________________________________________:151
5 	kernel32.dll 	BaseThreadStart
Whiteboard: [flash-11.3]
Whiteboard: [flash-11.3] → [flash-11.3] not protected mode, WinXP only
i was hoping this would be easy to reproduce, but i tried farmville, bingo and various other games on facebook without issue.  does anyone have any other STR to try?  thanks...
Marcia, we're still having problems reproducing.  

We think it's related to specific audio-drivers, based on where the crash occurs and the related changes on our side (we moved to DirectSound to minimize audio latency).

I'm wondering if there are any URLs that stick out now that our sample size is bigger, too.  

Thanks!
Duplicate of this bug: 778775
Here are some correlations that may help:

100% (286/286) vs.  41% (52205/128230) dsound.dll
          0% (0/286) vs.   0% (1/128230) 5.1.2600.2055
          0% (0/286) vs.   0% (1/128230) 5.3.0.900
          0% (1/286) vs.   0% (6/128230) 5.3.2600.2096
          0% (0/286) vs.   0% (3/128230) 5.3.2600.2149
         20% (58/286) vs.   2% (2122/128230) 5.3.2600.2180
          0% (0/286) vs.   0% (1/128230) 5.3.2600.3180
          0% (0/286) vs.   0% (2/128230) 5.3.2600.3205
          0% (0/286) vs.   0% (3/128230) 5.3.2600.3244
          0% (0/286) vs.   0% (13/128230) 5.3.2600.3264
          0% (0/286) vs.   0% (5/128230) 5.3.2600.3282
          0% (0/286) vs.   0% (14/128230) 5.3.2600.3311
          0% (0/286) vs.   0% (5/128230) 5.3.2600.5503
          0% (0/286) vs.   0% (6/128230) 5.3.2600.5508
         79% (227/286) vs.   7% (8741/128230) 5.3.2600.5512
          0% (0/286) vs.   0% (1/128230) 5.3.3790.1830
          0% (0/286) vs.   0% (17/128230) 5.3.3790.3959
          0% (0/286) vs.   0% (5/128230) 6.0.6000.16385
          0% (0/286) vs.   0% (518/128230) 6.0.6000.16386
          0% (0/286) vs.   1% (928/128230) 6.0.6001.18000
          0% (0/286) vs.   5% (5801/128230) 6.0.6002.18005
          0% (0/286) vs.   0% (1/128230) 6.1.6956.0
          0% (0/286) vs.   0% (2/128230) 6.1.7000.0
          0% (0/286) vs.   0% (1/128230) 6.1.7077.0
          0% (0/286) vs.   0% (27/128230) 6.1.7100.0
          0% (0/286) vs.   0% (1/128230) 6.1.7231.0
          0% (0/286) vs.   0% (5/128230) 6.1.7600.16384
          0% (0/286) vs.  26% (33899/128230) 6.1.7600.16385
          0% (0/286) vs.   0% (7/128230) 6.2.8102.0
          0% (0/286) vs.   0% (19/128230) 6.2.8250.0
          0% (0/286) vs.   0% (50/128230) 6.2.8400.0

As far as URLs, I don't see any more critical mass in recent data.  Facebook apps are the most well represented URL in the data set, but there is no one particular URL that stands out.

(In reply to Jeromie Clark from comment #3)
> Marcia, we're still having problems reproducing.  
> 
> We think it's related to specific audio-drivers, based on where the crash
> occurs and the related changes on our side (we moved to DirectSound to
> minimize audio latency).
> 
> I'm wondering if there are any URLs that stick out now that our sample size
> is bigger, too.  
> 
> Thanks!
We've introduced a change to Flash Player 11.4 (we're reverting back to using the WAV APIs on WinXP) that should address this crash.  It should be available in the next Flash Player 11.4 beta. 

If there are Mozilla employees or other folks under NDA that can reproduce this issue, I can share a build tomorrow for evaluation.
Dolores 11.4 shipped.  11.4.402.265 was released 8/21.  closing.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 11.x → unspecified
You need to log in before you can comment on or make changes to this bug.