URL Bar is displayed when rotating the device if Full Screen mode is set

VERIFIED FIXED in Firefox 20

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: xti, Assigned: kats)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 20
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox16 affected, firefox17 affected, firefox18 affected, firefox20 verified, fennec-)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 637118 [details]
screenshots

Firefox 16.0a1 (2012-06-27)
Device: Galaxy Nexus
OS: Android 4.0.2

Steps to reproduce:
1. Open Fennec
2. Go to http://people.mozilla.org/~mwargers/tests/videos/football.ogg
3. Long tap on video and tap on Full Screen option
4. Switch device orientation to landscape

Expected result:
URL Bar is not displayed after step 4.

Actual result:
URL Bar is displayed after step 4 (see attached screenshot).
(Reporter)

Comment 1

6 years ago
This issue is still reproducible on the latest Nightly.

Also the URL Bar will be permanently visible no matter what device orientation is set until the Back button is tapped to exit the full screen mode. If I tap on the URL Bar, the browser will quit full screen until I will dismiss the Awesomescreen, but still the URL Bar will be still visible in full screen mode.

--
Firefox 17.0a1 (2012-08-08)
Device: Galaxy Nexus
OS: Android 4.1.1
tracking-fennec: --- → ?
status-firefox17: --- → affected
Assignee: nobody → bnicholson
tracking-fennec: ? → -
(Reporter)

Updated

6 years ago
status-firefox16: --- → affected
status-firefox18: --- → affected
Duplicate of this bug: 799882
See similar bug 797104.
See Also: → bug 797104

Updated

6 years ago
Blocks: 800673
Created attachment 684793 [details] [diff] [review]
(1/2) Remove redundant method

No functional changes in this patch
Assignee: bnicholson → bugmail.mozilla
Attachment #684793 - Flags: review?(bnicholson)
Created attachment 684794 [details] [diff] [review]
(2/2) Retain visibility property on rotation
Attachment #684794 - Flags: review?(bnicholson)
Duplicate of this bug: 797104
Attachment #684793 - Flags: review?(bnicholson) → review+
Attachment #684794 - Flags: review?(bnicholson) → review+
https://hg.mozilla.org/mozilla-central/rev/ff09a887acd6
https://hg.mozilla.org/mozilla-central/rev/bf673653d9a3
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20

Updated

6 years ago
Status: RESOLVED → VERIFIED
status-firefox20: --- → verified
(Reporter)

Comment 9

6 years ago
This issue still occurs on the latest Nightly build.

--
Firefox 20.0a1 (2012-11-27)
Device: Galaxy Nexus
OS: Android 4.1.1
Status: VERIFIED → REOPENED
status-firefox20: verified → affected
Resolution: FIXED → ---
(Reporter)

Comment 10

6 years ago
However it works as expected on today's Nightly. The URL Bar is no longer displayed when switching the device orientation to landscape. Closing bug as verified fixed on:

Firefox 20.0a1 (2012-11-27)
Device: Galaxy Nexus
OS: Android 4.1.1
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

6 years ago
Wrong environment. Actually is:

Firefox 20.0a1 (2012-11-28)
Device: Galaxy Nexus
OS: Android 4.1.1
Status: RESOLVED → VERIFIED
status-firefox20: affected → verified
You need to log in before you can comment on or make changes to this bug.