Last Comment Bug 769304 - Add accessibility platform status to about:support
: Add accessibility platform status to about:support
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: 15 Branch
: x86_64 All
: -- normal (vote)
: mozilla16
Assigned To: Hubert Figuiere [:hub]
:
: alexander :surkov
Mentors:
Depends on: 759158 761589
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 08:54 PDT by Hubert Figuiere [:hub]
Modified: 2012-07-02 18:41 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add accessibility platform status to about:support. r= (2.86 KB, patch)
2012-06-28 14:26 PDT, Hubert Figuiere [:hub]
dbolter: review+
gavin.sharp: feedback+
mzehe: feedback+
Details | Diff | Splinter Review
Add accessibility platform status to about:support. (2.83 KB, patch)
2012-06-29 11:26 PDT, Hubert Figuiere [:hub]
dbolter: review+
Details | Diff | Splinter Review

Description Hubert Figuiere [:hub] 2012-06-28 08:54:57 PDT
Followup on bug 759158 and bug 761589. We should add the status of the "platform disabled" in about:support
Comment 1 Hubert Figuiere [:hub] 2012-06-28 14:26:36 PDT
Created attachment 637676 [details] [diff] [review]
Add accessibility platform status to about:support. r=
Comment 2 David Bolter [:davidb] 2012-06-29 06:57:00 PDT
Comment on attachment 637676 [details] [diff] [review]
Add accessibility platform status to about:support. r=

Review of attachment 637676 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with comments addressed. If my comments seem wrong please ping me.

::: toolkit/content/aboutSupport.js
@@ +422,5 @@
> +  forceDisabled = getPrefValue("accessibility.force_disabled").value;
> +
> +  document.getElementById("a11y-platform-force-disabled").textContent
> +    = (forceDisabled == -1) ? "forced enabled" :
> +	((forceDisabled == 1) ? "forced disabled" : "enabled");

What do you think about this:

In the dtd, aboutSupport.a11yForceDisabled = "Prevent Accessibility"

And then we could keep the numeric values? (Or maybe go with "never" for -1)

Gavin what do you think?

::: toolkit/content/aboutSupport.xhtml
@@ +258,5 @@
> +            <th class="column">
> +              &aboutSupport.a11yForceDisabled;
> +            </th>
> +
> +            <td id="a11y-platform-force-disabled">

Maybe "a11y-force-disabled" is simpler as it matches the pref (?) - If you have a specific reason to include "platform" that's fine.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-29 07:04:13 PDT
Comment on attachment 637676 [details] [diff] [review]
Add accessibility platform status to about:support. r=

accessibility.force_disabled already shows up in the "modified preferences" section, FWIW, but I guess you want to also add it here for easy reference? That's fine, I guess.

As David suggests, I would stick with just printing the pref value (and maybe use "Forced State" as the title, since that's what the pref seems to actually be about?)
Comment 4 Marco Zehe (:MarcoZ) 2012-06-29 07:16:46 PDT
Comment on attachment 637676 [details] [diff] [review]
Add accessibility platform status to about:support. r=

I'd go with Gavin's suggestion. After all this tells if accessibility is always, never, or conditionally instanciated.
Comment 5 David Bolter [:davidb] 2012-06-29 07:22:21 PDT
Sounds good.
Comment 6 David Bolter [:davidb] 2012-06-29 07:24:37 PDT
Wait. Forced State = 1 seems like a lie then (since it really means forced disabled).
Comment 7 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-29 09:23:19 PDT
Well that's your own fault for choosing weird -1/0/1 values :) I don't know what would make it clearer, maybe "Forced State Preference Value"?
Comment 8 Hubert Figuiere [:hub] 2012-06-29 11:04:28 PDT
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #7)
> Well that's your own fault for choosing weird -1/0/1 values :) I don't know
> what would make it clearer, maybe "Forced State Preference Value"?

I think "Prevent Accessibility" seems to be the easier to understand. Even though this is "diagnostic" information.
Comment 9 Hubert Figuiere [:hub] 2012-06-29 11:26:22 PDT
Created attachment 637949 [details] [diff] [review]
Add accessibility platform status to about:support.
Comment 10 Hubert Figuiere [:hub] 2012-06-29 13:56:43 PDT
Comment on attachment 637949 [details] [diff] [review]
Add accessibility platform status to about:support.

what do you thing of the new wording?
Comment 11 David Bolter [:davidb] 2012-06-29 16:36:36 PDT
Comment on attachment 637949 [details] [diff] [review]
Add accessibility platform status to about:support.

Fine with me.

Note You need to log in before you can comment on or make changes to this bug.