Status

()

bugzilla.mozilla.org
General
RESOLVED DUPLICATE of bug 264721
6 years ago
6 years ago

People

(Reporter: Annie Elliott, Unassigned)

Tracking

Production

Details

(Reporter)

Description

6 years ago
Metrics needs a new status: "REVIEWED" to go along with NEW, ASSIGNED, etc. to support our workflow.

"TRIAGED" would also work for us, specifically, but I suspect that "REVIEWED" would be more easily subsumed by more projects.

Thank you.
Normally we try not to add any additional statuses so as to keep the list short and simple. We instead advice people to utilize the Keywords functionality of Bugzilla. Could this be served just as well by adding a Reviewed keyword that can be selected in the Keywords field? You can then query for bugs that have or do not have the keyword set.

dkl
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 2

6 years ago
I totally get that. However, in this case, it's not so much what *is* in a field as what *isn't*

SO, unfortunately, it does not serve our needs. The most important thing is for us to be able to rapidly and uneqivocably identify NEW bugs that have never been seen or touched, and have some way of managing them out of the NEW status *before* they ever get to the ASSIGNED state.

I totally understand the need for tight control on such an important field, but given that most of MoCo uses Bugzilla for some level of project management (despite, I fully realise, the fact that it is a bug tracking tool) it would be really helpful to have a PM state in there.

I am just trying to ensure that our tickets get handled appropriately and do not languish, and using keywords and whiteboards to manage state transitions means I will have to own up to having some tickets slip through the cracks.

All that said, I rest my case ;) If the answer is still no, you will get no further argument, promise.
I think this actually be more appropriate for the READY state which was being discussed in the past about revamping BMO workflow.

https://wiki.mozilla.org/BugzillaWorkflowImprovements

IMO opinion there is enough consensus for us to go ahead and add the READY status to BMO now and then work out the other improvements in future pieces. The READY state would give a small win for now while we work out the other details.

Also adding SUPPORT resolution but that is another bug :)

Anyone have any objections?

dkl
(Reporter)

Comment 4

6 years ago
Thumbs up from me.
I have no objections to adding the READY state, because it looks like I won't have time in the near future to push through a general reconsideration of how we do this. But what is very important is that it's clear to everyone from the outset what this state is meant to signify. That involves documentation in Bugzilla but also a public awareness campaign with blogs and discussion forum posts. If the semantics are not clear, it will rapidly end up as not useful.

Gerv
So, this is now a dupe of bug 264721?
(Reporter)

Comment 7

6 years ago
I'm ok with that.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 264721
You need to log in before you can comment on or make changes to this bug.