java.lang.NoSuchMethodError: java.io.IOException.<init> at org.mozilla.gecko.sync.net.BaseResource.execute(BaseResource.java) on Froyo

RESOLVED FIXED in Firefox 16

Status

Android Background Services
Android Sync
--
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Scoobidiver (away), Assigned: nalexander)

Tracking

({crash})

unspecified
mozilla17
ARM
Android
crash

Firefox Tracking Flags

(firefox15 wontfix, firefox16 fixed)

Details

(Whiteboard: [native-crash][sync], crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
It's #58 top crasher in 14.0.
There are 2 crashes in 14.0b8 and 59 crashes in 14.0, including bp-0e80380d-a9d5-4054-8888-625b02120629.

java.lang.NoSuchMethodError: java.io.IOException.<init>
	at org.mozilla.gecko.sync.net.BaseResource.execute(BaseResource.java:264)
	at org.mozilla.gecko.sync.net.BaseResource.retryRequest(BaseResource.java:275)
	at org.mozilla.gecko.sync.net.BaseResource.execute(BaseResource.java:258)
	at org.mozilla.gecko.sync.net.BaseResource.go(BaseResource.java:299)
	at org.mozilla.gecko.sync.net.BaseResource.post(BaseResource.java:319)
	at org.mozilla.gecko.sync.net.SyncStorageRequest.post(SyncStorageRequest.java:170)
	at org.mozilla.gecko.sync.repositories.Server11RepositorySession$RecordUploadRunnable.run(Server11RepositorySession.java:607)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1068)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:561)
	at java.lang.Thread.run(Thread.java:1096)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NoSuchMethodError%3A+java.io.IOException.%3Cinit%3E+at+org.mozilla.gecko.sync.net.BaseResource.execute%28BaseResource.java%29

Updated

5 years ago
Duplicate of this bug: 784084
(Reporter)

Updated

5 years ago
Whiteboard: [native-crash] → [native-crash][sync]
Component: General → Android Sync
Product: Firefox for Android → Mozilla Services
Version: Firefox 14 → unspecified
(Assignee)

Comment 2

5 years ago
Ah, Android.  That constructor wasn't added until API level 9, per http://stackoverflow.com/a/8546380 and http://developer.android.com/intl/zh-CN/reference/java/io/IOException.html#IOException%28java.lang.Throwable%29

Let us try to work around it.
(Assignee)

Comment 3

5 years ago
(In reply to Nick Alexander :nalexander from comment #2)
> Ah, Android.  That constructor wasn't added until API level 9, ...

Further: a fly-by of reports suggest all devices were running 2.2/Froyo/API level 8.
(Assignee)

Updated

5 years ago
Assignee: nobody → nalexander

Comment 4

5 years ago
(In reply to Nick Alexander :nalexander from comment #3)
> (In reply to Nick Alexander :nalexander from comment #2)
> > Ah, Android.  That constructor wasn't added until API level 9, ...
> 
> Further: a fly-by of reports suggest all devices were running 2.2/Froyo/API
> level 8.

I for one was certainly running 2.2
(Reporter)

Updated

5 years ago
Summary: java.lang.NoSuchMethodError: java.io.IOException.<init> at org.mozilla.gecko.sync.net.BaseResource.execute(BaseResource.java) → java.lang.NoSuchMethodError: java.io.IOException.<init> at org.mozilla.gecko.sync.net.BaseResource.execute(BaseResource.java) on Froyo
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/91cba558c70c
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla17
(Assignee)

Comment 6

5 years ago
Created attachment 654248 [details] [diff] [review]
Patch against m-i

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 769671.
User impact if declined: continued crashes with signature of this bug.
Testing completed (on m-c, etc.): compiles on m-i; very difficult to test.
Risk to taking this patch (and alternatives if risky): none.  Crash is caused by Java initializer not being present in Android API level < 9; this trivial patch just avoids using that particular initializer.  If this patch is wrong, we'll just see similar crash reports on the same code path (possibly for more API versions).
String or UUID changes made by this patch: none.
Attachment #654248 - Flags: approval-mozilla-beta?
Attachment #654248 - Flags: approval-mozilla-aurora?
Attachment #654248 - Flags: review+

Comment 7

5 years ago
https://hg.mozilla.org/mozilla-central/rev/91cba558c70c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 654248 [details] [diff] [review]
Patch against m-i

Too late in the 15 cycle to take for beta, but uplift to Aurora in the next couple of days before that becomes Beta 16.
Attachment #654248 - Flags: approval-mozilla-beta?
Attachment #654248 - Flags: approval-mozilla-beta-
Attachment #654248 - Flags: approval-mozilla-aurora?
Attachment #654248 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/1fed79eac734
status-firefox15: --- → wontfix
status-firefox16: --- → fixed
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services
You need to log in before you can comment on or make changes to this bug.