Closed Bug 769712 Opened 9 years ago Closed 9 years ago

Unable to launch installed application from about:apps dashboard or notification tray

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect)

ARM
Android
defect
Not set
normal

Tracking

(blocking-kilimanjaro:?, firefox16 affected)

RESOLVED WONTFIX
blocking-kilimanjaro ?
Tracking Status
firefox16 --- affected

People

(Reporter: aaronmt, Unassigned)

References

Details

(Keywords: regression)

I am seeing this when installing 'Galactians 2' [1]. No shortcut is created, and in about:apps I see no icon but mere text that is still un-launchable. Alongside this, launching from the notification tray does not work as expected either

[1] https://marketplace.mozilla.org/en-US/app/galactians2/

On attempt to launch I see

E/GeckoConsole( 3711): No chrome package registered for chrome://browser/library/icon-128.png
I/GeckoAppShell( 3711): GeckoAppShell.showAlertNotification
I/GeckoAppShell( 3711): - image = 'drawable://alert_app'
I/GeckoAppShell( 3711): - title = 'Galactians2'
I/GeckoAppShell( 3711): - text = 'Successfully installed'
I/GeckoAppShell( 3711): - cookie = ''
I/GeckoAppShell( 3711): - name = 'webapp'
I/GeckoAppShell( 3711): Created notification ID -791806387
D/dalvikvm(  267): GC_CONCURRENT freed 2192K, 38% free 14625K/23431K, paused 2ms+5ms
E/GeckoConsole( 3711): [JavaScript Error: "CreateShortcut: favicon image load error" {file: "chrome://browser/content/browser.js" line: 5910}]

---

Manifest

    {  
      "version": "1.0",  
      "name": "Galactians2",  
      "description": "Blast, dodge and splat the swooping aliens. Look out for jelly bombs and guided missiles !",  
      "icons": {  
        "16": "/library/icon-16.png",  
        "48": "/library/icon-48.png",  
        "128": "/library/icon-128.png"  
      },  
      "developer": {  
        "name": "Space Monster Games",  
        "url": "http://www.spacemonstergames.co.uk"  
      },  
      "installs_allowed_from":   
        ["*"]  
      ,  
      "locales": {  
        "es": {  
          "description": "¡Acción abierta emocionante del desarrollo del Web!",  
          "developer": {  
            "url": "http://es.mozillalabs.com/"  
          }  
        },  
        "it": {  
          "description": "Azione aperta emozionante di sviluppo di fotoricettore!",  
          "developer": {  
            "url": "http://it.mozillalabs.com/"  
          }  
        }  
      },  
      "default_locale": "en"  
    }


--
Nightly (06/29)
Samsung Galaxy Nexus (Android 4.0.4)
tracking-fennec: --- → ?
This appears to be happening with every app right now. I can't launch the app from about:apps. No shortcut is being created. 

This also failed for Mozilla QA WebRT Tester and Favimon.
(In reply to Jason Smith [:jsmith] from comment #1)
> This appears to be happening with every app right now. I can't launch the
> app from about:apps. No shortcut is being created. 
> 
> This also failed for Mozilla QA WebRT Tester and Favimon.

Just tried another 3 apps - doesn't work either.
The default manifest for an app on testmanifest.com appears to work.
Summary: Unable to launch installed application from dashboard or notification tray; no shortcut is created → Cannot launch installed application from dashboard or notification tray; no shortcut is created that is using relative absolute paths for icons
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766808
Is this a dupe?

I just tested with a manifest:

{
   "name":"Mozilla Marketplace (Dev)",
   "default_locale":"en-US",
   "icons":{
      "128":"https://marketplace-dev-cdn.allizom.org/media/img/mkt/logos/128.png?b=90360cf",
      "32":"https://marketplace-dev-cdn.allizom.org/media/img/mkt/logos/32.png?b=90360cf",
      "64":"https://marketplace-dev-cdn.allizom.org/media/img/mkt/logos/64.png?b=90360cf"
   },
   "description":"The Mozilla Marketplace",
   "locales":{

   },
   "developer":{
      "url":"http://mozilla.org",
      "name":"Mozilla"
   }
}

with all absolute paths and no shortcut, or entry in about:apps was created
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(correction, I do get a shortcut, but no about:apps entry)
I am seeing shortcuts appearing that do launch the app, but the other two specified in comment 5 makes this sound like a different bug.
Summary: Cannot launch installed application from dashboard or notification tray; no shortcut is created that is using relative absolute paths for icons → Unable to launch installed application from about:apps dashboard or notification tray
Duplicate of this bug: 769734
QA Contact: aaron.train
Assignee: nobody → wjohnston
Priority: -- → P1
Can we get an update here? This is blocking testing in some areas.
Status: REOPENED → ASSIGNED
This is a confusing bug. I see two issues right now:

1.) Launching from a notification is broken. This is a race that we apparently started hitting. Have a fix. Will file a new bug and post there.

2.) About:apps not showing stuff. Not sure what's up there. Looking into it. Will file a separate bug for that too.
Filed bug 774422 and bug 774426. I'll mark them as blocking this.
Depends on: 774422, 774426
(In reply to Wesley Johnston (:wesj) from comment #10)
> This is a confusing bug. I see two issues right now:
> 
> 1.) Launching from a notification is broken. This is a race that we
> apparently started hitting. Have a fix. Will file a new bug and post there.
> 
> 2.) About:apps not showing stuff. Not sure what's up there. Looking into it.
> Will file a separate bug for that too.

My bad. I'd say let's just get rid of this bug and use the other two bugs for tracking.
Assignee: wjohnston → nobody
No longer blocks: Blocking-FFA-WebRT1+
Status: ASSIGNED → RESOLVED
Closed: 9 years ago9 years ago
No longer depends on: 774422, 774426
Priority: P1 → --
Resolution: --- → WONTFIX
tracking-fennec: ? → ---
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.