Last Comment Bug 769723 - Unnecessary kungFuDeathGrips in the idle API code
: Unnecessary kungFuDeathGrips in the idle API code
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: bsurender
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 715041
  Show dependency treegraph
 
Reported: 2012-06-29 11:04 PDT by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2012-08-09 08:21 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
OS Idle API kungFuDeathGrips and parentheses removed (bug 769722) (2.70 KB, patch)
2012-07-07 22:42 PDT, bsurender
jst: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-29 11:04:36 PDT
Since we removed the AddRef/Release across timer callbacks, those kungFuDeathGrips should be unnecessary.

http://hg.mozilla.org/integration/mozilla-inbound/rev/b405f493e834#l4.482
http://hg.mozilla.org/integration/mozilla-inbound/rev/b405f493e834#l4.502
http://hg.mozilla.org/integration/mozilla-inbound/rev/b405f493e834#l4.707
Comment 1 bsurender 2012-07-07 22:42:07 PDT
Created attachment 640023 [details] [diff] [review]
OS Idle API kungFuDeathGrips and parentheses removed (bug 769722)

This patch addresses the kung fu death grip and bug 769722, unecessary parentheses.

Loaded to try on bsurender@mozilla.com – Thu Jul 5 16:22:30 2012 PDT. Just got all of the test results for changeset 80e15cb53444.

https://tbpl.mozilla.org/?tree=Try&rev=80e15cb53444

Please look at adjacent green test results for tests that failed. Comments also added for Android test failures.
Comment 2 Johnny Stenback (:jst, jst@mozilla.com) 2012-07-10 13:30:17 PDT
Comment on attachment 640023 [details] [diff] [review]
OS Idle API kungFuDeathGrips and parentheses removed (bug 769722)

r=jst
Comment 3 Johnny Stenback (:jst, jst@mozilla.com) 2012-07-14 21:41:03 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/4c42f5fdc769
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-07-15 10:20:41 PDT
https://hg.mozilla.org/mozilla-central/rev/4c42f5fdc769

Note You need to log in before you can comment on or make changes to this bug.