[MLK] Leaking C strings in nsNSSComponent::ConfigureInternalPKCS11Token()

VERIFIED WONTFIX

Status

P3
normal
VERIFIED WONTFIX
18 years ago
2 years ago

People

(Reporter: beard, Assigned: javi)

Tracking

({memory-leak})

1.0 Branch
Future
memory-leak

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
All the calls to GetPK11String() in this method allocate strings. The call to  
PK11_ConfigurePKCS11() at the bottom of the method evidently copies all of those 
strings, thus all of the allocated strings leak. The URL above points to just one 
of the lines where a leaked string is allocated.
(Reporter)

Updated

18 years ago
Keywords: mlk
(Assignee)

Updated

18 years ago
Component: Libraries → Client Library
Product: NSS → PSM
Target Milestone: --- → 2.0
Version: 3.0 → 2.0
(Assignee)

Comment 1

18 years ago
This is a one time leak caused by NSS not freeing the strings passed in for
intializing the token names.  A possible work around is to declare our own
global static char arrays and populate and pass it to the PK11 libraries.

This is a one time less than 300 bytes.

Comment 2

18 years ago
->p3
Priority: -- → P3

Comment 3

18 years ago
Mass reassigning target to 2.1
Target Milestone: 2.0 → 2.1

Updated

18 years ago
Keywords: nsenterprise

Comment 4

18 years ago
remove nsenterprise.
Keywords: nsenterprise

Comment 5

18 years ago
Moving all P3 and P4 bugs targetted to 2.1 to future.
Target Milestone: 2.1 → Future

Updated

18 years ago
Blocks: 92580

Updated

17 years ago
No longer blocks: 92580

Comment 6

17 years ago
Changed the QA contact to Bishakha.
QA Contact: sonja.mirtitsch → bishakhabanerjee
This is not a PSM bug.

PSM by itself is not leaking (at least it does no longer leak, if it ever leaked
in the past).

PSM passes internal buffers of automatic strings to PK11_ConfigurePKCS11. It
will free the temporaray strings after the call.

If you think NSS is leaking and should free its strings on shutdown, please
reopen and change this into a NSS bug.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 9

17 years ago
Verified.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

11 years ago
Version: psm2.0 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.