If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Assertion failure: mInitialized, at widget/xpwidgets/nsTransferable.cpp:447" when dragging & dropping a file on Firefox

RESOLVED DUPLICATE of bug 769653

Status

()

Core
Widget
RESOLVED DUPLICATE of bug 769653
5 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({assertion})

Trunk
x86_64
Linux
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:
 0. Fire up a debug mozilla-central debug build. (w/ empty profile)
 1. Drag and drop a file (e.g. an empty .txt file) onto the Firefox window.

ACTUAL RESULTS:
 Assertion failure: mInitialized, at ../../../mozilla/widget/xpwidgets/nsTransferable.cpp:447

Likely a regression from http://hg.mozilla.org/mozilla-central/rev/93e55dcf0e2e for bug 722872 which added that assertion and was merged to m-c 2 days ago.
(Reporter)

Comment 1

5 years ago
Created attachment 638155 [details]
backtrace
(Reporter)

Comment 2

5 years ago
See also bug 769440, about Addon SDK hitting this same assertion during an automated test.
(May end up being the same underlying issue.)

Comment 3

5 years ago
Looks like a dup of bug 769653.
(Reporter)

Comment 4

5 years ago
Agreed, based on bug 769653 comment #2. Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769653
You need to log in before you can comment on or make changes to this bug.