The default bug view has changed. See this FAQ.

Intermittent test_sandbox.xul | Check number of loaded content types: application/javascript,text/html - got 2 (or 3), expected 4; or Check * was not loaded - -1 should equal -1

RESOLVED FIXED in mozilla16

Status

()

Core
Identity
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: philor, Assigned: MattN)

Tracking

({intermittent-failure})

Trunk
mozilla16
x86
Mac OS X
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15 unaffected, firefox16 affected, firefox17 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=13149210&tree=Firefox
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2012-07-01 09:06:26 PDT for push 3be950fe9e1e
slave: talos-r3-leopard-009

27544 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check successful response - 200 should equal 200
27545 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check number of loaded content types: application/javascript,text/html - got 2, expected 4
27546 ERROR TEST-UNEXPECTED-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check number of loaded content types: application/javascript,text/html - 2 should equal 2
27547 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check JS was loaded - 0 should not equal -1
27548 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check iframe was loaded - 1 should not equal -1
27549 ERROR TEST-UNEXPECTED-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check webm was not loaded - -1 should equal -1
27550 ERROR TEST-UNEXPECTED-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check ogg was not loaded - -1 should equal -1
Sandbox: free: 1657

https://tbpl.mozilla.org/php/getParsedLog.php?id=13150845&tree=Mozilla-Inbound
Rev3 MacOSX Leopard 10.5.8 mozilla-inbound debug test mochitest-other on 2012-07-01 12:47:02 PDT for push d444d01ef71c
slave: talos-r3-leopard-040

27599 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check successful response - 200 should equal 200
27600 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check number of loaded content types: application/javascript,text/html - got 2, expected 4
27601 ERROR TEST-UNEXPECTED-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check number of loaded content types: application/javascript,text/html - 2 should equal 2
27602 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check JS was loaded - 0 should not equal -1
27603 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check iframe was loaded - 1 should not equal -1
27604 ERROR TEST-UNEXPECTED-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check webm was not loaded - -1 should equal -1
27605 ERROR TEST-UNEXPECTED-PASS | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | Check ogg was not loaded - -1 should equal -1
27606 INFO TEST-INFO | chrome://mochitests/content/chrome/toolkit/identity/tests/chrome/test_sandbox.xul | reload the sandbox content
Sandbox: reload: 1679 : http://mochi.test:8888/chrome/toolkit/identity/tests/chrome/sandbox_content_redirect.html
++DOMWINDOW == 156 (0x3b25d85c) [serial = 1684] [outer = 0x33e90d20]
Sandbox: _makeSandboxContentLoaded : 1679 : http://mochi.test:8888/chrome/toolkit/identity/tests/chrome/sandbox_content.html
Sandbox: reloaded sandbox id:  : 1679
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Assignee: nobody → mnoorenberghe+bmo
Status: NEW → ASSIGNED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I increased the timeout interval for now to reduce this: https://hg.mozilla.org/integration/mozilla-inbound/rev/1dca83015433
Target Milestone: --- → mozilla16
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/1dca83015433
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
MattN, increasing the timeout limit doesn't seem to have helped. Any ideas?
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to Ed Morley [:edmorley] from comment #90)
> MattN, increasing the timeout limit doesn't seem to have helped. Any ideas?

I think it did help since it reduced the failures but not as much as I thought.  I made a patch to disable this portion of the test for 10.5 since that's where about 90% of the failures are and I don't have time to figure out the real cause at the moment.

Currently going through a try run: https://hg.mozilla.org/try/rev/67f31f74c489
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Created attachment 642178 [details] [diff] [review]
Disable most of check_loaded_content on 10.5

Not sure why it's been silent here the last 13 hours but we should probably disable this on 10.5 anyways.
Attachment #642178 - Flags: review?(dolske)
Comment on attachment 642178 [details] [diff] [review]
Disable most of check_loaded_content on 10.5

Thankfully there's no way this can break on 10.6 or 10.7... ahem. But good enough for now!
Attachment #642178 - Flags: review?(dolske) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
> Comment on attachment 642178 [details] [diff] [review]
> Disable most of check_loaded_content on 10.5

https://hg.mozilla.org/integration/mozilla-inbound/rev/7551b8fb7564
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/7551b8fb7564
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Summary: Intermittent test_sandbox.xul | Check number of loaded content types: application/javascript,text/html - got 2, expected 4 and three more failures → Intermittent test_sandbox.xul | Check number of loaded content types: application/javascript,text/html - got 2 (or 3), expected 4; and more failures
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
status-firefox15: --- → unaffected
status-firefox16: --- → affected
status-firefox17: --- → affected
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
MattN, do you have any ideas for this one?
(It is appearing on the orangefactor top oranges list)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Summary: Intermittent test_sandbox.xul | Check number of loaded content types: application/javascript,text/html - got 2 (or 3), expected 4; and more failures → Intermittent test_sandbox.xul | Check number of loaded content types: application/javascript,text/html - got 2 (or 3), expected 4; or Check * was not loaded - -1 should equal -1
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

5 years ago
Duplicate of this bug: 781497
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
MattN, ping for comment 196.
Comment hidden (Treeherder Robot)
(In reply to Ed Morley [:edmorley] from comment #196)
> MattN, do you have any ideas for this one?
> (It is appearing on the orangefactor top oranges list)

Some options in order of decreasing preference:
1) Fix bug 759964 then change these to expected passes
2) Change check_loaded_content to poll a few times until and wait longer for the webm/ogg to load
3) Increase the setTimeout intervals in check_disabled_content.  They are already at 5s which seems like ample time.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://tbpl.mozilla.org/php/getParsedLog.php?id=15239062&tree=Mozilla-Inbound
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)