Last Comment Bug 770369 - Update revision of Jetpack tests used on Mozilla-Aurora to fix tests
: Update revision of Jetpack tests used on Mozilla-Aurora to fix tests
Status: RESOLVED FIXED
:
Product: Testing
Classification: Components
Component: General (show other bugs)
: 15 Branch
: All All
: -- normal (vote)
: mozilla15
Assigned To: Wes Kocher (:KWierso)
:
:
Mentors:
Depends on:
Blocks: 764688
  Show dependency treegraph
 
Reported: 2012-07-02 16:03 PDT by Wes Kocher (:KWierso)
Modified: 2012-07-02 19:44 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Update revision of Jetpack code running on Mozilla-Aurora (651 bytes, patch)
2012-07-02 16:03 PDT, Wes Kocher (:KWierso)
wkocher: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Wes Kocher (:KWierso) 2012-07-02 16:03:07 PDT
Created attachment 638526 [details] [diff] [review]
Update revision of Jetpack code running on Mozilla-Aurora

+++ This bug was initially created as a clone of Bug #753628 +++

Bug 750307 landed, causing Jetpack tests to break on mozilla-central. We fixed the Jetpack bustage in bug 764688, and mozilla-central was green again. Last Thursday, bug 750307's patch landed on Aurora, causing Jetpack tests on that branch to break.

Earlier today, I landed a patch on mozilla-central to fix an unrelated test failure <https://hg.mozilla.org/integration/mozilla-inbound/rev/8c50b2ddc155>. I'd like to land that same patch on Mozilla-Aurora, to fix the bustage caused by bug 750307, as well as future-proof Aurora's Jetpack code against the bustage that was fixed in bug 769440. 

This patch updates the revision of the SDK that is used to run tests against the Firefox build. It's the same version that is currently being used against Central.


[Approval Request Comment]
Impact if declined: Jetpack tests on Aurora will continue to be orange on the tinderboxes. Future bustage on Aurora and eventually Beta might be masked by the current bustage.

Testing completed (on m-c, etc.): These tests are passing on mozilla-inbound with the patch applied there, and the tests are green on the Jetpack tree running against mozilla-central and mozilla-aurora.

Risk to taking this patch (and alternatives if risky): Risk is almost nothing, I believe. The Jetpack tests have yet to be unhidden on tbpl, and this isn't part of the build.
Comment 1 Ryan VanderMeulen [:RyanVM] 2012-07-02 19:44:43 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/15bea84a1130

Note You need to log in before you can comment on or make changes to this bug.