Last Comment Bug 770550 - rename FrameWorker.jsm exported symbol (FrameWorker -> getFrameWorkerHandle?)
: rename FrameWorker.jsm exported symbol (FrameWorker -> getFrameWorkerHandle?)
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 16
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
: Shane Caraveo (:mixedpuppy)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 08:51 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2012-07-04 06:37 PDT (History)
1 user (show)
gavin.sharp: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (12.42 KB, patch)
2012-07-03 08:57 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details | Diff | Splinter Review
patch (12.52 KB, patch)
2012-07-03 10:07 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
markh: review+
Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-03 08:51:57 PDT
Since this function isn't a constructor, and the returned object isn't a FrameWorker object, I think it makes sense to change the exported symbol's name.

I picked "getFrameWorkerHandle" because I'd chosen "WorkerHandle" in the previous patch. I'm not particularly attached to that name, though, and it is kind of ugly. Feedback desired!
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-03 08:57:39 PDT
Created attachment 638755 [details] [diff] [review]
patch
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-03 10:07:39 PDT
Created attachment 638782 [details] [diff] [review]
patch

This has a test fix.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-03 17:19:29 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a70007cba6bf
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-07-04 06:37:45 PDT
https://hg.mozilla.org/mozilla-central/rev/a70007cba6bf

Note You need to log in before you can comment on or make changes to this bug.