Since this function isn't a constructor, and the returned object isn't a FrameWorker object, I think it makes sense to change the exported symbol's name. I picked "getFrameWorkerHandle" because I'd chosen "WorkerHandle" in the previous patch. I'm not particularly attached to that name, though, and it is kind of ugly. Feedback desired!
Created attachment 638755 [details] [diff] [review] patch
Created attachment 638782 [details] [diff] [review] patch This has a test fix.