profile gets corrupted a lot

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Jim Michaels, Unassigned)

Tracking

14 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Build ID: 20120628060610

Steps to reproduce:

use firefox daily and upgrade when possible, repair filesystem if I have to power system off hard (so basically I try to do good system maintenance).


Actual results:

firefox profile gets corrupt. apparently, this happens so much to so many people, and so often, that mozilla seems to make it a point as part of their basic troubleshooting to "create a new profile".  apparently, I have to create a new profile every day or week. this means losing my tabs, which I don't like - I have 40-60 of them I want to keep, it is part of my development environment. it is causing ff strange behavior, and probably a lot of unnecessary bug reports.


Expected results:

profile should not corrupt so easily over time,especially such a short period of time. it might be caused by upgrades possibly. not sure. I don't know. if upgrades are a problem, the installer should convert the profile.
sanity checks should be in place to prevent ff from going nuts if possible. if it sees something wacky, it should notify the user that the profile is corrupt once at startup, and tell the person how to create a new profile, using "firefox -p".

see https://bugzilla.mozilla.org/show_bug.cgi?id=426018 for a feature request which solves the tab problem.

why not reduce the everybody's workload by possibly 2/3 by solving this very basic problem?
I'm using Mozilla since 1999 and I had to repair my profile only 4x and the last time was 6 years ago and I always use nightly builds.
My profile on my my system is 4years old.

Creating a new profile is basically only one step in troubleshooting an issue.
In most cases we don't do more because after identifying a broken profile the next step would be that the reporter tells us exactly what in the profile is broken and most people can't do that.
There are many parts in the profile like Cache, sqlite files, prefs.js, localstore.rdf ... and the exact file has to be identified.
This step can't be done by us because the issue is only on the users system and the files itself contain sensitive data.
After knowing the corrupt file we still don't know why it happens on your system but as example not on my system and we also don't know what is broken inside the file. 
BTW: Nightly builds contain a repair profile function that can be called from about:support
(Reporter)

Comment 2

6 years ago
sure would be nice if such a fix were in production/stable release versions. I think it would make a lot of people happy. me for one. anything that saves headache of losing my data over and over.

you say only 4x. I use (traditionally) the stable release. somehow, I am stuck on the beta release train. the only thing I get now is betas. I hope that's good.

so for me as a user and also as a QA tester, I (because of submitting bug reports and feature requests) repeatedly get urged by mozilla support and developers to "create a new profile". almost weekly/monthly.
or I don't get listened to.
(Reporter)

Comment 3

6 years ago
I don't know how often my profile really gets corrupted. it would be really cool if some sort of sanity checker were possible...

IF there were a button where the only thing it did was save my cookies and history and tabs and toss the rest and start over,this would be very useful indeed - maybe checkboxes for which of these I wanted to keep. I wouldn't even mind if I could re-create them from form sort of dialog that could maybe try to SAFELY import settings if need be. checkboxes for
- download location
- homepage
- what to do with tabs
- history
- tabs & tab groups & windows (these are usually just fine)
- cookies

this could be a sort of "Copy+Repair Profile" button which brings up a dialog in firefox -p

what do you think?
I'm not sure what to do with this report.
A bug report have to be limited to a single technical reason so that one developer can fix this issue in the code.
Multiple bugs are often in different areas of the code and different developers have to work on those issues. Different developers can't do the work in a single bug report since a bug report is the logbook of a single bug.
That's the reason why reports with multiple bugs are useless for a developer and have to be marked invalid.

Your problem looks like a single bug for a user but in reality it's more than one.
There are already tracking bugs open like bug 123929, bug 420106 and bug 63918
bug 717070 is already implemented and should help in your case !

A sanity check is already implemented in many places of the code. the sqlite or the prefs.js files are checked and a broken file will be replaced but that doesn't help with logical errors in those files. Those logical errors in the file are difficult to detect if not impossible and that's the reason why a simple task like "a sanity check" is difficult to do.

We are happy if someone reports a file x in my profile is corrupt. That is still a very difficult task for a developer to find out why this happened and to really fix it. Discarding the file is only an emergency fix and it makes future debugging nearly impossible since you will not get new reports about the issue in the future.

The "create a new profile" in the support is a different story.
I use it in bugzilla for finding the cause of a reported problem and I use it often as second step behind the safemode. I can be sure that the reported bug is not a bug in the Firefox code but it's the result of something wrong in the stored data if a new profile fixes it. In most cases the user can't find the corrupted file in the profile and providing a step by step instruction how to search for it is in most cases not possible.

A corrupted profile doesn't mean that the data in the old profile is corrupted by Firefox. A webserver could for example send wrong cookies once or wrong html files that are stored in the cache, an extension could switch hidden settings that exist only for debugging purposes in the prefs.js file (about:config). And then there a third party tools like a "cookie cleaner" that write to our database file and may break them.

The support is using the "new profile" because it's an easy thing that every user can do and it will solve the problem for the user. The main duty of the support is to make the make the user happy again and a "new profile" is a perfect tool for the support.

That's the difference to bugzilla. bugzilla exists to help our developers with their work (fixing bugs) and to make the product better. Everyone can report issues here but the developers need technical information that many users can not provide.

I hope you understand that i have to mark this report invalid because it's too general with many issues in one bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

6 years ago
if it helps any, I turned off cookie cleaning in mcafee. I have had mcafee for a long time. it is quite possible mcafee's plugins/extensions may be the culprit. they do cookie cleaning by default (I turned that off because it was driving me up the wall with useless action). now I find out it's probably corrupting my browser.

it's a major vendor antivirus package (mcafee total protection or mcafee virusscan). norton probably does something similar too I would guess. I will ask my friend. he has norton.

mcafee wastes at least 1/2 hour of time by cleaning cookies which are essentially inert and don't so anything. if anything, it's the marketing sites that create them that slow down the browser or halt it completely...
if I can create a mcafee "idea" (maybe combination bug report?) titled "remove browser-breaking cookie scans", I will refer it back to this bug report.

some cookies are used for plain old state-storage purposes and are needed for proper/convenient site operation (I had a tree menu that used cookies to store menu state so you didn't have to re-expand the page every time you visited that page/site). so if some user is reading this, some cookies are just plain needed if you don't want a really hard time using a site. some are bad. some are good.
(Reporter)

Comment 6

6 years ago
if you have nay more detailed insights to add that mcafee needs to know about regarding their plugins, please put it here.
(Reporter)

Comment 7

6 years ago
I mean, to keep their plugins and extensions from corrupting firefox. mcafee has 2 things in particular I would focus on.

siteadvisor: it changes search engine results and adds extra features, such as a mini site safety report. also flags bad sites if you attempt to visit them.

virusscan: includes a cookie scan. also scans files downloaded by the browser and flags them if they are bad. has realtime scanner and manual scanner. I think it is flagging spam with thunderbird, but doesn't delete them.  maybe next version 2012?
maybe I have to make a feature request.

norton has equivalents to these.
Norton or mcafee can corrupt cookies but I don't know if they are really do something bad.
Accessing cookies with a firefox extensions should not corrupt the database file but an extension can modify, add or remove cookies which may break sites.
External tools that are accessing the files could be more dangerous. An example for such an external tool is CCleaner (I don't day that this tool damages the file !).

My really personal opinion is that all this firewall extensions shouldn't be used. 
I have seen many issues caused by those extension in the past and they don't add more security.
Firefox, Seamonkey and Thunderbird are calling the installed virus scanner for each downloaded file and the background scanner will also catch every file.
You need to log in before you can comment on or make changes to this bug.