Closed Bug 77077 Opened 21 years ago Closed 21 years ago

often crashes on program close

Categories

(Core :: Networking: Cache, defect)

x86
Windows 2000
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 76372

People

(Reporter: stephena, Assigned: asa)

Details

(Whiteboard: [cache])

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.8.1+)
Gecko/20010415
BuildID:    2001041508

Periodically mozilla will crash on program close.  This happens on the close of
the last Mozilla window.  Not to be confused with other bugs that are on the
closing of "a" window.  Also, I've seen this happen for quite a while.  It
happens sometimes after I just went to a new url and then close.  I've also seen
it happen after I had an old page sitting open for an hour and finally got
around to closing mozilla.

Talkbacks:
TB28870832M
TB29202959H
TB29300998G
TB29433145Z
deffering to asa to whip those talkback datas out.
A more recent talkback of the crash:  TB29532952Y
ChangeTable [d:\builds\seamonkey\mozilla\xpcom\ds\pldhash.c, line 328]
PL_DHashTableEnumerate [d:\builds\seamonkey\mozilla\xpcom\ds\pldhash.c, line 481]
nsCacheEntryHashTable::Finalize
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheEntry.cpp, line 567]
PL_DHashTableFinish [d:\builds\seamonkey\mozilla\xpcom\ds\pldhash.c, line 227]
nsMemoryCacheDevice::~nsMemoryCacheDevice
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsMemoryCacheDevice.cpp]
nsMemoryCacheDevice::`scalar deleting destructor'
nsCacheService::Shutdown
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheService.cpp, line 291]
nsCacheService::Observe
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheService.cpp, line 1071]
nsObserverService::Notify
[d:\builds\seamonkey\mozilla\xpcom\ds\nsObserverService.cpp, line 238]
NS_ShutdownXPCOM [d:\builds\seamonkey\mozilla\xpcom\build\nsXPComInit.cpp, line 449]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1311]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1321]
WinMainCRTStartup()
KERNEL32.DLL + 0x7903 (0x77e87903)
Assignee: asa → gordon
Component: Browser-General → Networking: Cache
QA Contact: doronr → tever
oops, misfire on component change.
Assignee: gordon → asa
Component: Networking: Cache → Browser-General
QA Contact: tever → doronr
Whiteboard: [cache]
sounds somewhat like 76372...
When I posted this I had no idea how to make this reproducible.  I just filed a
bug for a similar (or perhaps subset) of these crashes.  The new bug is 100%
reproducible and a talkback comparison could probably tell whether the two are
the same bug.  The new one is bug 78007
Yes, I believe this is a duplicate of bug 76327.  Marking as such.


*** This bug has been marked as a duplicate of 76327 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Duplicate bug typo.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 76372 ***
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → DUPLICATE
VERIFIED duplicate
Status: RESOLVED → VERIFIED
Component: Browser-General → Networking: Cache
QA Contact: doron → benc
Summary: Mozilla often crashes on program close → often crashes on program close
You need to log in before you can comment on or make changes to this bug.