resizer.xml visible in the debugger

RESOLVED FIXED in Firefox 16

Status

()

Firefox
Developer Tools: Debugger
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: paul, Assigned: past)

Tracking

Trunk
Firefox 17
x86
All
Points:
---

Firefox Tracking Flags

(firefox15 affected, firefox16- fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 639086 [details]
screenshot

STR:
- open about:blank
- open the debugger
- open the Responsive Mode
(Reporter)

Comment 1

5 years ago
I can't reproduce. Maybe fixed already.

Comment 2

5 years ago
STR work for me on Win 7 with the latest Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 (Built from http://hg.mozilla.org/mozilla-central/rev/87db9617a885).

After opening the responsive view, the debugger loads resizer.xml:

<?xml version="1.0"?>
<!-- This Source Code Form is subject to the terms of the Mozilla Public
   - License, v. 2.0. If a copy of the MPL was not distributed with this
   - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->


<bindings id="resizerBindings"
   xmlns="http://www.mozilla.org/xbl">

  <binding id="resizer">
    <resources>
      <stylesheet src="chrome://global/skin/resizer.css"/>
    </resources>
    <implementation>
      <constructor>
      <![CDATA[
        // don't do this for viewport resizers; causes a crash related to
        // bugs 563665 and 581536 otherwise
        if (this.parentNode == this.ownerDocument.documentElement)
          return;

        // if the direction is rtl, set the rtl attribute so that the
        // stylesheet can use this to make the cursor appear properly
        var direction = window.getComputedStyle(this, "").direction;
        if (direction == "rtl") {
          this.setAttribute("rtl", "true");
        }
      ]]>
      </constructor>
    </implementation>
  </binding>

</bindings>

Comment 3

5 years ago
There's a screenshot in bug 767390 that also shows resizer.xml in the Debugger.
Priority: -- → P2
Assignee: nobody → past
Status: NEW → ASSIGNED
Related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=760882
See Also: → bug 760882
Created attachment 653413 [details] [diff] [review]
Working patch

OK, so the fact that it took me so long to see what is wrong here, is rather embarrassing. Apparently though a holiday can seriously clear your mind!
Attachment #653413 - Flags: review?(rcampbell)
Wow...
Comment on attachment 653413 [details] [diff] [review]
Working patch

Seem to be able to trigger this with a reload while the debugger's active. This should fix.
Attachment #653413 - Flags: review?(rcampbell) → review+
doesn't apply to beta, would like to include it in aurora and beta as it's a pretty basic patch that pre-empts some user confusion.
tracking-firefox15: --- → ?
tracking-firefox16: --- → ?
Created attachment 654138 [details] [diff] [review]
Patch for beta

This applies cleanly to beta.
Attachment #654138 - Flags: review?(rcampbell)
https://hg.mozilla.org/integration/fx-team/rev/df17d6a5a330
Whiteboard: [fixed-in-fx-team]
Comment on attachment 654138 [details] [diff] [review]
Patch for beta

we missed the boat on beta. Sorry.
Attachment #654138 - Flags: review?(rcampbell) → review-
tracking-firefox15: ? → ---
Comment on attachment 653413 [details] [diff] [review]
Working patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature. 
User impact if declined: users may see mysterious system scripts in the debugger during reloads.
Testing completed (on m-c, etc.): on m-c, local
Risk to taking this patch (and alternatives if risky): negligible.
String or UUID changes made by this patch:  none

I think this should apply fairly easily on aurora, requesting approval.
Attachment #653413 - Flags: approval-mozilla-aurora?
Comment on attachment 653413 [details] [diff] [review]
Working patch

I don't see the need to track this for 16, we can approve for Aurora though.
Attachment #653413 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
tracking-firefox16: ? → -
https://hg.mozilla.org/mozilla-central/rev/df17d6a5a330
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 17
Landed in aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/805e936380ab
status-firefox15: --- → affected
status-firefox16: --- → fixed
You need to log in before you can comment on or make changes to this bug.