If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Ignore role="presentation" when element is target of aria relation.

RESOLVED DUPLICATE of bug 575976

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 575976
5 years ago
5 years ago

People

(Reporter: davidb, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ARIA conformance])

Attachments

(1 attachment)

Comment hidden (empty)
No longer depends on: 765878
Created attachment 639332 [details]
Test case

Although FF does put the text into the acc description, we lose the relationship. The argument is that the spec requires we keep the relationship so that AT can perform things like "jump to the described content" operations.
We'll likely need to get clever here to avoid perf kill.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575976
You need to log in before you can comment on or make changes to this bug.